summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-17 08:20:01 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-17 08:20:01 +0000
commitd08b8b7db9f1402f8ce6a20bc050fd78f7b2b31b (patch)
tree273055e35b0fb59af68136b62011642d6817e7b5 /net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild
parentFix dev-util/intltool DEPEND (by Jan Psota). (diff)
downloadhistorical-d08b8b7db9f1402f8ce6a20bc050fd78f7b2b31b.tar.gz
historical-d08b8b7db9f1402f8ce6a20bc050fd78f7b2b31b.tar.bz2
historical-d08b8b7db9f1402f8ce6a20bc050fd78f7b2b31b.zip
Version bump for bug #324529. Add explicit DEPEND and use src_prepare instead of src_unpack.
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild')
-rw-r--r--net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild b/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild
new file mode 100644
index 000000000000..857fdddec0f2
--- /dev/null
+++ b/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/phpldapadmin/phpldapadmin-1.2.0.5.ebuild,v 1.1 2011/02/17 08:20:01 radhermit Exp $
+
+EAPI="2"
+
+inherit webapp depend.php
+
+DESCRIPTION="phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server."
+HOMEPAGE="http://phpldapadmin.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[hash,ldap,session,xml,nls]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+need_httpd_cgi
+need_php_httpd
+
+src_prepare() {
+ mv config/config.php.example config/config.php
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc INSTALL
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r *
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall2-en.txt
+
+ webapp_src_install
+}