summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-24 06:37:23 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-24 06:37:23 +0000
commitef849e391fe788b04c6fd1f22a97cc47d8b13b64 (patch)
tree965b0b75e06f91719801d32a6282e47a991ab549 /net-nds/ypbind/ypbind-1.17.2-r1.ebuild
parentimplemented a nsfw (offensive) USE flag to allow users to explicitly enable q... (diff)
downloadhistorical-ef849e391fe788b04c6fd1f22a97cc47d8b13b64.tar.gz
historical-ef849e391fe788b04c6fd1f22a97cc47d8b13b64.tar.bz2
historical-ef849e391fe788b04c6fd1f22a97cc47d8b13b64.zip
Revision bump to fix init scripts. Now depending on domainname to set ypdomainname. Stable x86, sparc, amd64.
Diffstat (limited to 'net-nds/ypbind/ypbind-1.17.2-r1.ebuild')
-rw-r--r--net-nds/ypbind/ypbind-1.17.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-nds/ypbind/ypbind-1.17.2-r1.ebuild b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
new file mode 100644
index 000000000000..c2ddf2e8d3c2
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2-r1.ebuild,v 1.1 2004/07/24 06:37:23 eradicator Exp $
+
+MY_P=${PN}-mt-${PV}
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64 ~ia64 ~ppc64"
+IUSE="nls"
+
+DEPEND="net-nds/yp-tools
+ net-nds/portmap"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog README THANKS TODO
+ insinto /etc ; doins etc/yp.conf
+ insinto /etc/conf.d ; newins ${FILESDIR}/ypbind.confd-r1 ypbind
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ypbind.initd ypbind
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /etc/conf.d/ypbind."
+ einfo "If you are using dhcpcd, be sure to add the -Y option to"
+ einfo "dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering"
+ einfo "/etc/yp.conf."
+}