summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-05-07 06:43:55 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-05-07 06:43:55 +0000
commitd5e0239802509b950d1d893094031d4c910b6cad (patch)
tree0c978b59ac212eb9a30c3d3dff58a45e22995161 /net-news
parentversion bump (diff)
downloadhistorical-d5e0239802509b950d1d893094031d4c910b6cad.tar.gz
historical-d5e0239802509b950d1d893094031d4c910b6cad.tar.bz2
historical-d5e0239802509b950d1d893094031d4c910b6cad.zip
version bump
Diffstat (limited to 'net-news')
-rw-r--r--net-news/pan/Manifest4
-rw-r--r--net-news/pan/files/digest-pan-0.14.01
-rw-r--r--net-news/pan/pan-0.14.0.ebuild49
3 files changed, 52 insertions, 2 deletions
diff --git a/net-news/pan/Manifest b/net-news/pan/Manifest
index 0735e4536098..037417ac7bd5 100644
--- a/net-news/pan/Manifest
+++ b/net-news/pan/Manifest
@@ -1,8 +1,8 @@
MD5 bc8bfe3865fc56e57033a3cfad9b3aa6 pan-0.13.4.ebuild 1295
MD5 f925b49585830f8d1434e7c43eeb65f0 pan-0.13.3.ebuild 1113
MD5 96021cac39fd14cce3a90ca403eccfa5 pan-0.13.0.ebuild 1108
-MD5 5a7891c4fa9c9e295a2205a38a61a337 ChangeLog 4275
-MD5 781bccabe849ab308be9127d25abedd4 pan-0.14.0.ebuild 1285
+MD5 004ed5181a05bf50ccf3652422ebbc15 ChangeLog 4393
+MD5 2b8b2e23ade3d27ec72f752a4d89a841 pan-0.14.0.ebuild 1288
MD5 cff0105db43ec12604bd9c2987c0ab89 files/digest-pan-0.13.0 64
MD5 e67e883e39b3cba048e38d29f5808479 files/digest-pan-0.13.3 64
MD5 c5d7d32aaa4f21e5935f14527f971c78 files/digest-pan-0.13.4 125
diff --git a/net-news/pan/files/digest-pan-0.14.0 b/net-news/pan/files/digest-pan-0.14.0
new file mode 100644
index 000000000000..8523157915d1
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.14.0
@@ -0,0 +1 @@
+MD5 b2702adadb84c2e0d52d2bb029c05206 pan-0.14.0.tar.bz2 1753632
diff --git a/net-news/pan/pan-0.14.0.ebuild b/net-news/pan/pan-0.14.0.ebuild
new file mode 100644
index 000000000000..20e4b63aeaa8
--- /dev/null
+++ b/net-news/pan/pan-0.14.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.14.0.ebuild,v 1.1 2003/05/07 06:43:47 phosphan Exp $
+
+IUSE="spell"
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.22
+ >=net-libs/gnet-1.1.5
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ sys-devel/gettext"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+ local myconf=""
+
+ # Likely that glibc might of been compiled with nls turned off.
+ # Warn people that Pan requires glibc to have nls support.
+ if [ -z "`use nls`" ]; then
+ ewarn "Pan requires glibc to be merged with 'nls' in your USE flags."
+ fi
+
+ use spell \
+ && myconf="${myconf} --enable-gtkspell" \
+ || myconf="${myconf} --disable-gtkspell"
+
+ econf ${myconf} || die "Configure failure"
+
+ emake || die "Compilation failure"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}