summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-08-30 01:33:02 +0000
committerJon Hood <squinky86@gentoo.org>2006-08-30 01:33:02 +0000
commit6e4eede659c5a3108ea116da2741857ff7a60b74 (patch)
treebdf280c23e501a0915e2b4fb40353ae7c14df97a /net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild
parentUpdated atlas-3.7.15-shared-libs.patch in order for it to also work with the ... (diff)
downloadhistorical-6e4eede659c5a3108ea116da2741857ff7a60b74.tar.gz
historical-6e4eede659c5a3108ea116da2741857ff7a60b74.tar.bz2
historical-6e4eede659c5a3108ea116da2741857ff7a60b74.zip
Version bump, amd64 fix for sha1, bug #139915.
Package-Manager: portage-2.1.1_rc1-r1
Diffstat (limited to 'net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild')
-rw-r--r--net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild b/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild
new file mode 100644
index 000000000000..48b5cf46f252
--- /dev/null
+++ b/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild,v 1.1 2006/08/30 01:33:02 squinky86 Exp $
+
+inherit eutils
+
+IUSE="xml"
+
+DESCRIPTION="The giFT Gnutella plugin"
+HOMEPAGE="http://gift.sf.net/"
+SRC_URI="mirror://sourceforge/gift/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/libxml2"
+
+RDEPEND=">=net-p2p/gift-0.11.6"
+
+src_compile() {
+ econf $(use_with xml libxml) || die "failed to configure"
+ emake || die "failed to build"
+}
+
+src_install() {
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/$(get_libdir)/giFT \
+ datadir=${D}/usr/share \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+}
+
+pkg_postinst() {
+ einfo "It is recommended that you re-run gift-setup as"
+ einfo "the user you will run the giFT daemon as:"
+ einfo "\tgift-setup"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/giftd.conf configuration file:"
+ einfo "plugins = Gnutella"
+ echo
+ einfo "To update your caches, run:"
+ einfo "\tsh /usr/portage/net-p2p/${PN}/files/cacheupdate.sh"
+}