summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-11 21:38:13 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-11 21:38:13 +0000
commit9316e8ea3adc765ea2b0387f40bfcc42341b8503 (patch)
treec8f2ce29f5bfd10abf12a7d20b5acf8ddd02d333 /net-p2p/giftcurs/giftcurs-0.6.2.ebuild
parentcorrecting einfo. closes 36277 (diff)
downloadhistorical-9316e8ea3adc765ea2b0387f40bfcc42341b8503.tar.gz
historical-9316e8ea3adc765ea2b0387f40bfcc42341b8503.tar.bz2
historical-9316e8ea3adc765ea2b0387f40bfcc42341b8503.zip
Version bumped. closes 38334
Diffstat (limited to 'net-p2p/giftcurs/giftcurs-0.6.2.ebuild')
-rw-r--r--net-p2p/giftcurs/giftcurs-0.6.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-p2p/giftcurs/giftcurs-0.6.2.ebuild b/net-p2p/giftcurs/giftcurs-0.6.2.ebuild
new file mode 100644
index 000000000000..8b8789a70dea
--- /dev/null
+++ b/net-p2p/giftcurs/giftcurs-0.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftcurs/giftcurs-0.6.2.ebuild,v 1.1 2004/02/11 21:38:13 mholzer Exp $
+
+MY_P="giFTcurs-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A ncurses frontend to the giFT (OpenFT) daemon"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.nongnu.org/giftcurs/"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gpm nls"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=dev-libs/glib-2.0"
+
+RDEPEND="${DEPEND}
+ net-p2p/gift"
+
+src_compile() {
+ local myconf=""
+
+ use gpm || myconf="${myconf} --disable-mouse --disable-libgpm"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf $myconf || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog NEWS README THANKS TODO
+}