summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2004-03-10 00:07:56 +0000
committerHanno Boeck <hanno@gentoo.org>2004-03-10 00:07:56 +0000
commitb7027e77991fc3a9124d18ab7e5d2c772bf8aa54 (patch)
tree01bb25ed93229f3211df12f4ff46a25dd55535b4 /net-p2p/mldonkey/mldonkey-2.5.16.ebuild
parentVersion bump. (diff)
downloadhistorical-b7027e77991fc3a9124d18ab7e5d2c772bf8aa54.tar.gz
historical-b7027e77991fc3a9124d18ab7e5d2c772bf8aa54.tar.bz2
historical-b7027e77991fc3a9124d18ab7e5d2c772bf8aa54.zip
mldonkey version bump.
Diffstat (limited to 'net-p2p/mldonkey/mldonkey-2.5.16.ebuild')
-rw-r--r--net-p2p/mldonkey/mldonkey-2.5.16.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/net-p2p/mldonkey/mldonkey-2.5.16.ebuild b/net-p2p/mldonkey/mldonkey-2.5.16.ebuild
new file mode 100644
index 000000000000..eb8d31026b34
--- /dev/null
+++ b/net-p2p/mldonkey/mldonkey-2.5.16.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mldonkey/mldonkey-2.5.16.ebuild,v 1.1 2004/03/10 00:07:56 hanno Exp $
+
+inherit eutils
+
+IUSE="gtk"
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="mldonkey is a new client to access the eDonkey network. It is written in Objective-Caml, and comes with its own GTK GUI, an HTTP interface and a telnet interface."
+HOMEPAGE="http://www.nongnu.org/mldonkey/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~ia64"
+
+
+DEPEND="gtk? ( =dev-ml/lablgtk-1.2.5 )
+ >=dev-lang/ocaml-3.06
+ dev-lang/perl"
+RDEPEND="net-misc/wget"
+
+MLUSER="p2p"
+
+src_compile() {
+ use gtk || export GTK_CONFIG="no"
+
+ # the dirs are not (yet) used, but it doesn't hurt to specify them anyway
+ econf \
+ --sysconfdir=/etc/mldonkey \
+ --sharedstatedir=/var/mldonkey \
+ --localstatedir=/var/mldonkey \
+ --enable-batch
+
+ emake || die
+}
+
+src_install() {
+ dobin mlnet
+ use gtk && dobin mlchat mlgui mlguistarter mlim mlnet+gui
+ dobin ${FILESDIR}/mldonkey
+
+ dodoc ChangeLog Copying.txt Developers.txt Install.txt
+ cd ${S}/distrib
+ dodoc ChangeLog Authors.txt Bugs.txt Copying.txt Developers.txt Install.txt Readme.txt Todo.txt ed2k_links.txt
+ dohtml FAQ.html
+
+ insinto /usr/share/doc/${PF}/scripts
+ doins kill_mldonkey mldonkey_command mldonkey_previewer
+
+ insinto /usr/share/doc/${PF}/distrib
+ doins directconnect.ini
+
+ cd ${S}/docs
+ dodoc *.txt *.tex *.pdf
+ dohtml *.html
+
+ cd ${S}/docs/developers
+ dodoc *.txt *.tex
+
+ cd ${S}/docs/images
+ insinto /usr/share/doc/${PF}/html/images
+ doins *
+
+ insinto /etc/conf.d; newins ${FILESDIR}/mldonkey.confd mldonkey
+ exeinto /etc/init.d; newexe ${FILESDIR}/mldonkey.initd mldonkey
+
+ # add user
+ enewuser ${MLUSER} -1 /bin/bash /home/p2p users
+}
+
+pkg_postinst() {
+ echo
+ einfo "Running \`mldonkey' will start the server inside ~/.mldonkey/"
+ einfo "If you want to start mldonkey in a particular working directory,"
+ einfo "use the \`mlnet' command."
+ einfo "If you want to start mldonkey as a system service, use"
+ einfo "the /etc/init.d/mldonkey script. To control bandwidth, use"
+ einfo "the 'slow' and 'fast' arguments. Be sure to have a look at"
+ einfo "/etc/conf.d/mldonkey also."
+ echo
+}