summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2006-12-06 23:09:42 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2006-12-06 23:09:42 +0000
commitf972c9a5afc859390688f4fc21152f0801af0d2c (patch)
tree23780802f71e304be48caab64c958471a89027b0 /net-p2p/opendchub/opendchub-0.7.15.ebuild
parentAdded patches for malformed build.xml files. (diff)
downloadhistorical-f972c9a5afc859390688f4fc21152f0801af0d2c.tar.gz
historical-f972c9a5afc859390688f4fc21152f0801af0d2c.tar.bz2
historical-f972c9a5afc859390688f4fc21152f0801af0d2c.zip
Version bump, added --enable-switch_user to configure script, bug #71149
Package-Manager: portage-2.1.2_pre2-r7
Diffstat (limited to 'net-p2p/opendchub/opendchub-0.7.15.ebuild')
-rw-r--r--net-p2p/opendchub/opendchub-0.7.15.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/opendchub/opendchub-0.7.15.ebuild b/net-p2p/opendchub/opendchub-0.7.15.ebuild
new file mode 100644
index 000000000000..8c98b3cc6afc
--- /dev/null
+++ b/net-p2p/opendchub/opendchub-0.7.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/opendchub/opendchub-0.7.15.ebuild,v 1.1 2006/12/06 23:09:42 sekretarz Exp $
+
+inherit eutils
+
+DESCRIPTION="hub software for Direct Connect"
+HOMEPAGE="http://opendchub.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
+IUSE="perl"
+
+DEPEND="perl? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/opendchub-gentoo.patch
+ epatch ${FILESDIR}/"0.7.14-telnet.patch"
+ epatch ${FILESDIR}/"0.7.14-overflow.patch"
+}
+
+src_compile() {
+ ! use perl && myconf="--disable-perl --enable-switch_user"
+ econf $myconf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+ if use perl ; then
+ exeinto /usr/bin
+ doexe ${FILESDIR}/opendchub_setup.sh
+ dodir /usr/share/opendchub/scripts
+ insinto /usr/share/opendchub/scripts
+ doins Samplescripts/*
+ fi
+ dodoc Documentation/*
+}
+
+pkg_postinst() {
+ if use perl ; then
+ einfo
+ einfo "To set up perl scripts for opendchub to use, please run"
+ einfo "opendchub_setup.sh as the user you will be using opendchub as."
+ einfo
+ fi
+}