summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-06-10 18:53:14 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-06-10 18:53:14 +0000
commit0ad8fdb29372c67e199a68fb2e0c53866e5e89e4 (patch)
tree9fb1e3e4191f8c7507176b33a7174b596bfd227e /net-p2p
parentthis.makework_and_rename (diff)
downloadhistorical-0ad8fdb29372c67e199a68fb2e0c53866e5e89e4.tar.gz
historical-0ad8fdb29372c67e199a68fb2e0c53866e5e89e4.tar.bz2
historical-0ad8fdb29372c67e199a68fb2e0c53866e5e89e4.zip
this.makework_and_rename
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gift-cvs/Manifest4
-rw-r--r--net-p2p/gift-cvs/files/digest-gift-cvs-0.10.0-r2 (renamed from net-p2p/gift-cvs/files/digest-gift-cvs-0.12.0)0
-rw-r--r--net-p2p/gift-cvs/gift-cvs-0.10.0-r2.ebuild (renamed from net-p2p/gift-cvs/gift-cvs-0.12.0.ebuild)22
3 files changed, 11 insertions, 15 deletions
diff --git a/net-p2p/gift-cvs/Manifest b/net-p2p/gift-cvs/Manifest
index 631510a969d2..0633c0a6dcaf 100644
--- a/net-p2p/gift-cvs/Manifest
+++ b/net-p2p/gift-cvs/Manifest
@@ -1,5 +1,5 @@
-MD5 9666ecd648aec4268d91f0401a79654e gift-cvs-0.10.0-r2.ebuild 2747
+MD5 79b6aade4d7652193e585c2dfdb123c9 gift-cvs-0.10.0-r2.ebuild 2753
MD5 d3a8edef24632770acea87143985a8d3 gift-cvs-0.10.0.ebuild 1244
-MD5 cc79056a96e12e658644986cf64be847 ChangeLog 1417
+MD5 5e56db38f03ea7ab826fafab4c53768d ChangeLog 1821
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gift-cvs-0.10.0-r2 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gift-cvs-0.10.0 0
diff --git a/net-p2p/gift-cvs/files/digest-gift-cvs-0.12.0 b/net-p2p/gift-cvs/files/digest-gift-cvs-0.10.0-r2
index e69de29bb2d1..e69de29bb2d1 100644
--- a/net-p2p/gift-cvs/files/digest-gift-cvs-0.12.0
+++ b/net-p2p/gift-cvs/files/digest-gift-cvs-0.10.0-r2
diff --git a/net-p2p/gift-cvs/gift-cvs-0.12.0.ebuild b/net-p2p/gift-cvs/gift-cvs-0.10.0-r2.ebuild
index f5eba7316b3d..66afa28f7e4e 100644
--- a/net-p2p/gift-cvs/gift-cvs-0.12.0.ebuild
+++ b/net-p2p/gift-cvs/gift-cvs-0.10.0-r2.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/gift-cvs-0.12.0.ebuild,v 1.3 2003/06/10 02:24:28 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/gift-cvs-0.10.0-r2.ebuild,v 1.1 2003/06/10 18:53:10 lostlogic Exp $
DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network client"
HOMEPAGE="http://gift.sourceforge.net"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="-x86 -sparc -ppc"
+KEYWORDS="~x86 ~sparc ~ppc"
DEPENDS="virtual/glibc
- >=sys-apps/sed-4
- >=sys-libs/zlib-1.1.4"
+ >=sys-apps/sed-4
+ >=sys-libs/zlib-1.1.4"
inherit cvs debug flag-o-matic
@@ -55,12 +55,8 @@ src_compile() {
# Compile the FastTrack plugin. The developers of this thing sure as hell don't like automated installs.
cd ${S}/FastTrack
- sed -i -e "s:\$(HOME)/.giFT:${D}/etc/giFT:" \
- -e "s:/usr/local/lib/giFT:${D}/usr/lib/giFT:" \
- -e "s:LIBGIFT_CFLAGS =:#LIBGIFT_CFLAGS =:" \
- -e "s:LIBGIFT_LDFLAGS =:#LIBGIFT_LDFLAGS =:" Makefile
- sed -i -e "s:#include <libgift/proto/:#include <../plugin/:" \
- -e "s:#include <libgift/:#include <../lib/:" *.c *.h
+ cp /usr/share/libtool/ltmain.sh .
+ ./autogen.sh --prefix=/usr --host=${CHOST} || die "FastTrack configure failed"
emake || die "FastTrack plugin failed to build"
}
@@ -76,7 +72,7 @@ src_install() {
libgiftincdir=${D}/usr/include/libgift || die "Install failed"
# Install the FastTrack plugin.
cd ${S}/FastTrack
- einstall || "FastTrack plugin failed to install"
+ make DESTDIR="${D}" install || "FastTrack plugin failed to install"
# Fix the giFT-setup executable.
cd ${D}/usr/bin
@@ -89,10 +85,10 @@ pkg_postinst() {
einfo "user account to create the giFT configuration files."
echo
einfo "To run giFT with FastTrack support, run:"
- einfo "giFT -p /usr/lib/giFT/FastTrack.so"
+ einfo "giFT -p /usr/lib/giFT/libFastTrack.so"
echo
einfo "Alternatively you can add the following line to"
einfo "your ~/.giFT/gift.conf configuration file:"
- einfo "plugins = OpenFT:/usr/lib/giFT/FastTrack.so"
+ einfo "plugins = OpenFT:/usr/lib/giFT/libFastTrack.so"
}