summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-03-01 16:15:10 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-03-01 16:15:10 +0000
commit63b5a11f7f39260297081cbdb2cc9dd060ec43d5 (patch)
tree6a345ca9cb9ca51425caa6f801ff1642f3a58e6c /net-p2p
parentUnmask rb_libtorrent svn snapshort, for use in net-p2p/lince. (diff)
downloadhistorical-63b5a11f7f39260297081cbdb2cc9dd060ec43d5.tar.gz
historical-63b5a11f7f39260297081cbdb2cc9dd060ec43d5.tar.bz2
historical-63b5a11f7f39260297081cbdb2cc9dd060ec43d5.zip
Initial ebuild for bug #211831, thanks to Federico Moro <zayer at frikis dot org>.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/lince/ChangeLog10
-rw-r--r--net-p2p/lince/Manifest4
-rw-r--r--net-p2p/lince/lince-0.99.ebuild28
-rw-r--r--net-p2p/lince/metadata.xml24
4 files changed, 66 insertions, 0 deletions
diff --git a/net-p2p/lince/ChangeLog b/net-p2p/lince/ChangeLog
new file mode 100644
index 000000000000..db15dcb8dc63
--- /dev/null
+++ b/net-p2p/lince/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-p2p/lince
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/ChangeLog,v 1.1 2008/03/01 16:15:10 coldwind Exp $
+
+*lince-0.99 (01 Mar 2008)
+
+ 01 Mar 2008; Santiago M. Mola <coldwind@gentoo.org> +lince-0.99.ebuild:
+ Initial ebuild for bug #211831, thanks to Federico Moro <zayer at frikis dot
+ org>.
+
diff --git a/net-p2p/lince/Manifest b/net-p2p/lince/Manifest
new file mode 100644
index 000000000000..92d088f17516
--- /dev/null
+++ b/net-p2p/lince/Manifest
@@ -0,0 +1,4 @@
+DIST lince-0.99.tar.gz 654476 RMD160 ed08bdc467d45b3c18d8624eee70a18c8df68e45 SHA1 ccb2b131663ad16e0d542575069b10ba3440bcca SHA256 b9d67107a9ba4c1ca322fb15b6393cfa3fd54049f5b5c879492be04d1b86b763
+EBUILD lince-0.99.ebuild 718 RMD160 8a8076e2c072daadc521e2713ba36be2de8f5a6c SHA1 4ec80118e752744a68c5ced5dc0ec8361b4dc757 SHA256 12a3cc81d7744700d9339fd0e07de2ea0db9749d87b23fe43daa4baaab483327
+MISC ChangeLog 390 RMD160 c051fba6d6b69dd73717cca1fe9b1bce1506210b SHA1 b4cc8cb13b0c088ee2272ea34ebff3aff5491913 SHA256 770c7a8a77e48164bbc78129d3bece82654a308f2dd24d5be3926c84f68cedc7
+MISC metadata.xml 863 RMD160 d7c862d6f880e531774f901b82f5e7170f7567a6 SHA1 ff186ca589ce56290f761c4e2e56550d050100b1 SHA256 8a7440b0412b03110f8e13149a6f5b281859e5413a6bf82e41ac04b5f196e1f0
diff --git a/net-p2p/lince/lince-0.99.ebuild b/net-p2p/lince/lince-0.99.ebuild
new file mode 100644
index 000000000000..3a2ec1566701
--- /dev/null
+++ b/net-p2p/lince/lince-0.99.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/lince-0.99.ebuild,v 1.1 2008/03/01 16:15:10 coldwind Exp $
+
+DESCRIPTION="a light, powerfull and full feature gtkmm bittorrent client"
+SRC_URI="mirror://sourceforge/lincetorrent/${P}.tar.gz"
+HOMEPAGE="http://lincetorrent.sourceforge.net"
+
+DEPEND="dev-cpp/gtkmm
+ x11-libs/cairo
+ >=net-libs/rb_libtorrent-0.13_pre1912
+ dev-libs/libxml2"
+
+RDEPEND="${DEPEND}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nls"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/net-p2p/lince/metadata.xml b/net-p2p/lince/metadata.xml
new file mode 100644
index 000000000000..1decb1a37028
--- /dev/null
+++ b/net-p2p/lince/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+<maintainer>
+ <email>coldwind@gentoo.org</email>
+ <name>Santiago M. Mola</name>
+</maintainer>
+ <longdescription>Lince Torrent is a torrent client based on rb_libtorrent,
+ and gtkmm. It aims to be a light and full featured client. Some of its
+ highlighted features are:
+ * UPnP / NAT-PMP port forwarding support.
+ * Encryption support (compatible with Azureus).
+ * Multiple simultaneous downloads / uploads.
+ * DHT (trackerless) support.
+ * uTorrent Peer eXchange support (PeX).
+ * Selective download of files in a torrent
+ * Torrent trackers edition.
+ * System tray integration
+ * Unicode support
+ * Connection though a proxy
+ * IP Filtering similar to the one in eMule
+ </longdescription>
+</pkgmetadata>