summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-06-07 02:01:45 +0000
committerDonny Davies <woodchip@gentoo.org>2002-06-07 02:01:45 +0000
commit8a74f382f9f5a93d022584bc1ce12e130e1745fb (patch)
treef8ea95d33989294cd595a4b13d395fbea9aba038 /net-print/hpijs
parentclose #3218 (diff)
downloadhistorical-8a74f382f9f5a93d022584bc1ce12e130e1745fb.tar.gz
historical-8a74f382f9f5a93d022584bc1ce12e130e1745fb.tar.bz2
historical-8a74f382f9f5a93d022584bc1ce12e130e1745fb.zip
close #3080
Diffstat (limited to 'net-print/hpijs')
-rw-r--r--net-print/hpijs/ChangeLog8
-rw-r--r--net-print/hpijs/files/digest-hpijs-1.11
-rw-r--r--net-print/hpijs/hpijs-1.1.ebuild39
3 files changed, 45 insertions, 3 deletions
diff --git a/net-print/hpijs/ChangeLog b/net-print/hpijs/ChangeLog
index ec8f5f3700f9..e2ff9216d81c 100644
--- a/net-print/hpijs/ChangeLog
+++ b/net-print/hpijs/ChangeLog
@@ -1,9 +1,11 @@
# ChangeLog for net-print/hpijs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/ChangeLog,v 1.1 2002/04/10 19:37:53 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/ChangeLog,v 1.2 2002/06/07 02:01:45 woodchip Exp $
-*hpijs-1.0.4 (10 Apr 2002)
+*hpijs-1.1 (6 Jun 2002)
+ 6 Jun 2002; Donny Davies <woodchip@gentoo.org> :
+ Chase latest release, add LICENSE + SLOT; close #3080.
+*hpijs-1.0.4 (10 Apr 2002)
10 Apr 2002; Donny Davies <woodchip@gentoo.org> hpijs-1.0.4.ebuild :
-
New package contributed by Steve Flack <steve_flack@ntlworld.com>.
diff --git a/net-print/hpijs/files/digest-hpijs-1.1 b/net-print/hpijs/files/digest-hpijs-1.1
new file mode 100644
index 000000000000..9a0efb0c3fdb
--- /dev/null
+++ b/net-print/hpijs/files/digest-hpijs-1.1
@@ -0,0 +1 @@
+MD5 be2ae5eb4e80a4cdce56a11fbde655fc hpijs-1.1.tar.gz 283448
diff --git a/net-print/hpijs/hpijs-1.1.ebuild b/net-print/hpijs/hpijs-1.1.ebuild
new file mode 100644
index 000000000000..dfbddc441885
--- /dev/null
+++ b/net-print/hpijs/hpijs-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.1.ebuild,v 1.1 2002/06/07 02:01:45 woodchip Exp $
+
+# Though this program runs on it's own it makes no sense to run it without ghostscript
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The HP Inkjet server for Ghostscript. Provides best output for HP Inkjet Printers"
+HOMEPAGE="http://hpinkjet.sourceforge.net"
+SRC_URI="mirror://sourceforge/hpinkjet/${P}.tar.gz"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND} app-text/ghostscript"
+LICENSE="as-is"
+SLOT="0"
+
+src_compile () {
+ econf --host=${CHOST} || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install () {
+ einstall || die
+ # fix the doc dir, it needs to have the package revision..
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+}
+
+pkg_postinst () {
+ if [ "`use cups`" ] ; then
+ einfo "To use the hpijs driver with the cups spooler, you will need the .ppd file"
+ einfo "for your printer. You may obtain it from:"
+ einfo "http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "Install it in /usr/share/cups/model. After restarting cups you should be"
+ einfo "able to use the new driver"
+ else
+ einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ driver file"
+ einfo "for your printer from http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
+ einfo "This file should be installed in /etc/pdq/drivers"
+ fi
+}