summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-31 00:59:37 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-31 00:59:37 +0000
commitcfb7180f5e862dd17b356812cec13eccaf15db74 (patch)
tree0b4217e6297fb91d9a97bdc75df4faae0a1fe3e8 /net-proxy
parentclean relative path (diff)
downloadhistorical-cfb7180f5e862dd17b356812cec13eccaf15db74.tar.gz
historical-cfb7180f5e862dd17b356812cec13eccaf15db74.tar.bz2
historical-cfb7180f5e862dd17b356812cec13eccaf15db74.zip
econf doesnt need `die`; tweak style in a few places
Package-Manager: portage-2.2.0_alpha10/cvs/Linux x86_64
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.8.1-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-proxy/tinyproxy/tinyproxy-1.8.1-r1.ebuild b/net-proxy/tinyproxy/tinyproxy-1.8.1-r1.ebuild
index ab95d52c16ee..296e41790479 100644
--- a/net-proxy/tinyproxy/tinyproxy-1.8.1-r1.ebuild
+++ b/net-proxy/tinyproxy/tinyproxy-1.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/tinyproxy-1.8.1-r1.ebuild,v 1.3 2010/06/04 05:28:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/tinyproxy-1.8.1-r1.ebuild,v 1.4 2010/12/31 00:59:37 vapier Exp $
EAPI="2"
@@ -29,8 +29,8 @@ src_prepare() {
use minimal && epatch "${FILESDIR}/${P}-minimal.patch"
sed -i etc/${PN}.conf.in -e "s|nobody|${PN}|g" || die "sed failed"
sed \
- "${FILESDIR}/${PN}.initd" \
-e "/CONFFILE/s:${PN}/::g" \
+ "${FILESDIR}/${PN}.initd" \
> "${WORKDIR}"/${PN}.initd \
|| die "sed failed"
eautoreconf
@@ -48,8 +48,7 @@ src_configure() {
$(use_enable transparent-proxy transparent) \
$(use_enable upstream-proxy upstream) \
$(use_enable xtinyproxy-header xtinyproxy) \
- $(use_enable debug) \
- || die "econf failed"
+ $(use_enable debug)
}
src_install() {
@@ -70,6 +69,6 @@ src_install() {
}
pkg_postinst() {
- einfo "For filtering domains and URLs, enable filter option in the configuration file"
- einfo "and add them to the filter file (one domain or URL per line)."
+ einfo "For filtering domains and URLs, enable filter option in the configuration"
+ einfo "file and add them to the filter file (one domain or URL per line)."
}