summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-04-21 12:11:28 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-04-21 12:11:28 +0000
commitaebdf01f8c95e2e6832c50ed7d24c09bf6717884 (patch)
tree89b97c69bf86388cff58a6a9f19fcfd1a235e577 /net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
parentadd ~arm, bug #412489 (diff)
downloadhistorical-aebdf01f8c95e2e6832c50ed7d24c09bf6717884.tar.gz
historical-aebdf01f8c95e2e6832c50ed7d24c09bf6717884.tar.bz2
historical-aebdf01f8c95e2e6832c50ed7d24c09bf6717884.zip
Initial commit.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild')
-rw-r--r--net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
new file mode 100644
index 000000000000..8db1fc66ae5d
--- /dev/null
+++ b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild,v 1.1 2012/04/21 12:11:28 chithanh Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit cmake-utils git-2 python
+
+DESCRIPTION="GNU Radio source block for OsmoSDR and rtlsdr"
+HOMEPAGE="http://sdr.osmocom.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-libs/boost
+ net-wireless/gnuradio
+ net-wireless/rtl-sdr"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 "${S}"
+}