summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-01-14 15:07:09 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-01-14 15:07:09 +0000
commit55498073221e3c233bc13014faf3ab1c7de29200 (patch)
tree182068f43bc4b50c56cc8045c53d2c0fa12c9446 /net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
parentstable x86, bug 279367 (diff)
downloadhistorical-55498073221e3c233bc13014faf3ab1c7de29200.tar.gz
historical-55498073221e3c233bc13014faf3ab1c7de29200.tar.bz2
historical-55498073221e3c233bc13014faf3ab1c7de29200.zip
Adding support for FAST-EAP, fixing bug #300215.
Package-Manager: portage-2.2_rc61/cvs/Linux i686
Diffstat (limited to 'net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index 9bcba97f3d62..0e9deb9418a0 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild,v 1.2 2009/05/22 08:11:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild,v 1.3 2010/01/14 15:07:09 gurligebis Exp $
EAPI="2"
inherit eutils toolchain-funcs qt3 qt4
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="http://w1.fi/hostap.git"
+ EGIT_REPO_URI="git://w1.fi/srv/git/hostap.git"
inherit git
SRC_URI=""
S="${WORKDIR}/${P}/${PN}/${PN}"
@@ -23,7 +23,7 @@ LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
KEYWORDS="-*"
-IUSE="dbus debug gnutls eap-sim madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
+IUSE="dbus debug gnutls eap-sim fasteap madwifi ps3 qt3 qt4 readline ssl wps kernel_linux kernel_FreeBSD"
DEPEND="dev-libs/libnl
dbus? ( sys-apps/dbus )
@@ -58,6 +58,10 @@ src_unpack() {
}
pkg_setup() {
+ if use fasteap && (use gnutls || use ssl) ; then
+ die "If you use fasteap, you must build with wpa_supplicant's internal TLS implementation. That is, both 'gnutls' and 'ssl' USE flags must be disabled"
+ fi
+
if use gnutls && use ssl ; then
einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
fi
@@ -88,7 +92,7 @@ src_prepare() {
-e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
wpa_supplicant.conf || die
- epatch "${FILESDIR}"/dbus_path_fix.patch
+ epatch "${FILESDIR}"/${P}-dbus_path_fix.patch
}
src_configure() {
@@ -134,6 +138,10 @@ src_configure() {
echo "CONFIG_PCSC=y" >> .config
fi
+ if use fasteap ; then
+ echo "CONFIG_EAP_FAST=y" >> .config
+ fi
+
if use readline ; then
# readline/history support for wpa_cli
echo "CONFIG_READLINE=y" >> .config