summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-03-03 12:33:58 +0000
committerPeter Volkov <pva@gentoo.org>2010-03-03 12:33:58 +0000
commit25187694daf960d20f0b2d648c006ccca859535d (patch)
treeb1b1bed7c3fc027805080e70e3680ac0f96c8d95 /net-wireless
parentVersion bump dev-util/boost-build to 1.42.0. (diff)
downloadhistorical-25187694daf960d20f0b2d648c006ccca859535d.tar.gz
historical-25187694daf960d20f0b2d648c006ccca859535d.tar.bz2
historical-25187694daf960d20f0b2d648c006ccca859535d.zip
Version bump, bug #306851, thank Oschtan for report and Andrey for explanation of the problem.
Package-Manager: portage-2.2_rc62/cvs/Linux i686
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/madwifi-ng-tools/ChangeLog11
-rw-r--r--net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4119.20100201.ebuild70
-rw-r--r--net-wireless/madwifi-ng/ChangeLog11
-rw-r--r--net-wireless/madwifi-ng/madwifi-ng-0.9.4.4119.20100201.ebuild96
4 files changed, 184 insertions, 4 deletions
diff --git a/net-wireless/madwifi-ng-tools/ChangeLog b/net-wireless/madwifi-ng-tools/ChangeLog
index 273a9004390b..0403dc527bcb 100644
--- a/net-wireless/madwifi-ng-tools/ChangeLog
+++ b/net-wireless/madwifi-ng-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/madwifi-ng-tools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng-tools/ChangeLog,v 1.41 2009/10/24 13:15:18 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng-tools/ChangeLog,v 1.42 2010/03/03 12:32:36 pva Exp $
+
+*madwifi-ng-tools-0.9.4.4119.20100201 (03 Mar 2010)
+
+ 03 Mar 2010; Peter Volkov <pva@gentoo.org>
+ +madwifi-ng-tools-0.9.4.4119.20100201.ebuild:
+ Version bump, bug #306851, thank Oschtan for report and Andrey for
+ explanation of the problem.
24 Oct 2009; nixnut <nixnut@gentoo.org>
madwifi-ng-tools-0.9.4.4030.20090529.ebuild:
diff --git a/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4119.20100201.ebuild b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4119.20100201.ebuild
new file mode 100644
index 000000000000..e58bd2127cc4
--- /dev/null
+++ b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4119.20100201.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4119.20100201.ebuild,v 1.1 2010/03/03 12:32:36 pva Exp $
+
+EAPI="2"
+
+inherit versionator toolchain-funcs
+
+MY_PN=${PN/-ng-tools/}
+MY_PV=$(get_version_component_range 1-3)
+MY_REV=$(get_version_component_range 4)
+MY_DATE=$(get_version_component_range 5)
+MY_P=${MY_PN}-${MY_PV}-r${MY_REV}-${MY_DATE}
+S=${WORKDIR}/${MY_P}/tools
+
+DESCRIPTION="Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards"
+HOMEPAGE="http://www.madwifi-project.org/"
+SRC_URI="http://snapshots.madwifi-project.org/${MY_PN}-${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!net-wireless/madwifi-old-tools"
+
+src_prepare() {
+ # format string fix from solar
+ #sed -i \
+# -e 's:err(1, ifr.ifr_name);:err(1, "%s", ifr.ifr_name);:g' \
+# ${S}/tools/athstats.c || die
+
+ sed -i \
+ -e "s:CC =.*:CC = $(tc-getCC):" \
+ -e "s:CFLAGS=:CFLAGS+=:" \
+ -e "s:LDFLAGS=:LDFLAGS+=:" \
+ "${S}"/Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR=/usr/bin MANDIR=/usr/share/man STRIP=echo \
+ install || die "emake install failed"
+
+ dodir /sbin
+ mv "${D}"/usr/bin/wlanconfig "${D}"/sbin
+
+ # install headers for use by
+ # net-wireless/wpa_supplicant and net-wireless/hostapd
+ cd "${S}"/..
+ insinto /usr/include/madwifi/include/
+ doins include/*.h
+ insinto /usr/include/madwifi/net80211
+ doins net80211/*.h
+}
+
+pkg_postinst() {
+ if [ -e "${ROOT}"/etc/udev/rules.d/65-madwifi.rules ]; then
+ ewarn
+ ewarn "The udev rules for creating interfaces (athX) are no longer needed."
+ ewarn
+ ewarn "You should manually remove the /etc/udev/rules.d/65-madwifi.rules file"
+ ewarn "and either run 'udevstart' or reboot for the changes to take effect."
+ ewarn
+ fi
+ einfo
+ einfo "If you use net-wireless/wpa_supplicant or net-wireless/hostapd with madwifi"
+ einfo "you should remerge them now."
+ einfo
+}
diff --git a/net-wireless/madwifi-ng/ChangeLog b/net-wireless/madwifi-ng/ChangeLog
index 2f5bbf5f8524..844695f37f31 100644
--- a/net-wireless/madwifi-ng/ChangeLog
+++ b/net-wireless/madwifi-ng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/madwifi-ng
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/ChangeLog,v 1.72 2009/10/24 13:15:52 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/ChangeLog,v 1.73 2010/03/03 12:33:58 pva Exp $
+
+*madwifi-ng-0.9.4.4119.20100201 (03 Mar 2010)
+
+ 03 Mar 2010; Peter Volkov <pva@gentoo.org>
+ +madwifi-ng-0.9.4.4119.20100201.ebuild:
+ Version bump, bug #306851, thank Oschtan for report and Andrey for
+ explanation of the problem.
24 Oct 2009; nixnut <nixnut@gentoo.org>
madwifi-ng-0.9.4.4030.20090529.ebuild:
diff --git a/net-wireless/madwifi-ng/madwifi-ng-0.9.4.4119.20100201.ebuild b/net-wireless/madwifi-ng/madwifi-ng-0.9.4.4119.20100201.ebuild
new file mode 100644
index 000000000000..c931ddd61652
--- /dev/null
+++ b/net-wireless/madwifi-ng/madwifi-ng-0.9.4.4119.20100201.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/madwifi-ng-0.9.4.4119.20100201.ebuild,v 1.1 2010/03/03 12:33:58 pva Exp $
+
+EAPI="2"
+
+inherit linux-mod versionator
+
+MY_PN=${PN/-ng/}
+MY_PV=$(get_version_component_range 1-3)
+MY_REV=$(get_version_component_range 4)
+MY_DATE=$(get_version_component_range 5)
+MY_P=${MY_PN}-${MY_PV}-r${MY_REV}-${MY_DATE}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Next Generation driver for Atheros based IEEE 802.11a/b/g wireless LAN cards"
+HOMEPAGE="http://www.madwifi-project.org/"
+SRC_URI="http://snapshots.madwifi-project.org/${MY_PN}-${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="atheros-hal
+ || ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="injection"
+
+RDEPEND="!net-wireless/madwifi-old
+ net-wireless/wireless-tools
+ ~net-wireless/madwifi-ng-tools-${PV}"
+
+pkg_setup() {
+ CONFIG_CHECK="CRYPTO WIRELESS_EXT SYSCTL"
+ kernel_is lt 2 6 29 && CONFIG_CHECK="${CONFIG_CHECK} KMOD"
+ ERROR_CRYPTO="${P} requires Cryptographic API support (CONFIG_CRYPTO)."
+ ERROR_WIRELESS_EXT="${P} requires CONFIG_WIRELESS_EXT selected by Wireless LAN drivers (non-hamradio) & Wireless Extensions"
+ kernel_is gt 2 6 33 && \
+ ERROR_WIRELESS_EXT="${P} requires CONFIG_WIRELESS_EXT selected by some Wireless LAN drivers (e.g CONFIG_IPW2100)"
+ ERROR_SYSCTL="${P} requires Sysctl support (CONFIG_SYSCTL)."
+ ERROR_KMOD="${F} requires CONFIG_KMOD to be set to y or m"
+ BUILD_TARGETS="all"
+ MODULESD_ATH_PCI_DOCS="README"
+ linux-mod_pkg_setup
+
+ MODULE_NAMES='ath_hal(net:"${S}"/ath_hal)
+ wlan(net:"${S}"/net80211)
+ wlan_acl(net:"${S}"/net80211)
+ wlan_ccmp(net:"${S}"/net80211)
+ wlan_tkip(net:"${S}"/net80211)
+ wlan_wep(net:"${S}"/net80211)
+ wlan_xauth(net:"${S}"/net80211)
+ wlan_scan_sta(net:"${S}"/net80211)
+ wlan_scan_ap(net:"${S}"/net80211)
+ ath_rate_amrr(net:"${S}"/ath_rate/amrr)
+ ath_rate_onoe(net:"${S}"/ath_rate/onoe)
+ ath_rate_sample(net:"${S}"/ath_rate/sample)
+ ath_rate_minstrel(net:"${S}"/ath_rate/minstrel)
+ ath_pci(net:"${S}"/ath)'
+
+ BUILD_PARAMS="KERNELPATH=${KV_OUT_DIR}"
+}
+
+src_prepare() {
+ use injection && epatch "${FILESDIR}"/${PN}-injection-r3925.patch
+ for dir in ath ath_hal net80211 ath_rate ath_rate/amrr ath_rate/minstrel ath_rate/onoe ath_rate/sample; do
+ convert_to_m "${S}/${dir}/Makefile"
+ done
+ sed -e 's:-Werror ::' -i Makefile.inc || die "sed -Werror failed"
+ make svnversion.h || die
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README THANKS SNAPSHOT || die
+}
+
+pkg_postinst() {
+ local moddir="${ROOT}/lib/modules/${KV_FULL}/net/"
+
+ linux-mod_pkg_postinst
+
+ einfo
+ einfo "Interfaces (athX) are now automatically created upon loading the ath_pci"
+ einfo "module."
+ einfo
+ einfo "The type of the created interface can be controlled through the 'autocreate'"
+ einfo "module parameter."
+ einfo
+ einfo "As of net-wireless/madwifi-ng-0.9.3 rate control module selection is done at"
+ einfo "module load time via the 'ratectl' module parameter."
+
+ elog "Please note: This release is based off of 0.9.3.3 and NOT trunk."
+ elog "# No AR5007 support in this release;"
+ elog "experimental support is available for i386 (32bit) in #1679"
+ elog "# No AR5008 support in this release; support is available in trunk "
+ elog "No, we will not apply the patch from 1679, if you must, please do so
+ in an overlay on your system. That is upstreams ticket 1679, not Gentoo's."
+}