summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-04-23 17:10:08 +0000
committerStuart Herbert <stuart@gentoo.org>2004-04-23 17:10:08 +0000
commit40fc33e88ab7697212665a0d3cfe951a1b737fe0 (patch)
tree2508906a8e1413dc54b512e7684f3035be7a23e8 /net-www/bugzilla
parentFixed IUSE. (diff)
downloadhistorical-40fc33e88ab7697212665a0d3cfe951a1b737fe0.tar.gz
historical-40fc33e88ab7697212665a0d3cfe951a1b737fe0.tar.bz2
historical-40fc33e88ab7697212665a0d3cfe951a1b737fe0.zip
Fix for bug #46436
Diffstat (limited to 'net-www/bugzilla')
-rw-r--r--net-www/bugzilla/ChangeLog7
-rw-r--r--net-www/bugzilla/Manifest4
-rw-r--r--net-www/bugzilla/bugzilla-2.17.6-r2.ebuild130
-rw-r--r--net-www/bugzilla/files/digest-bugzilla-2.17.6-r21
4 files changed, 140 insertions, 2 deletions
diff --git a/net-www/bugzilla/ChangeLog b/net-www/bugzilla/ChangeLog
index d7954ac6e728..427e97127c23 100644
--- a/net-www/bugzilla/ChangeLog
+++ b/net-www/bugzilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/bugzilla
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/bugzilla/ChangeLog,v 1.4 2004/04/17 16:02:11 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/bugzilla/ChangeLog,v 1.5 2004/04/23 17:10:08 stuart Exp $
+
+*bugzilla-2.17.6-r2 (23 Apr 2004)
+
+ 23 Apr 2004; Stuart Herbert <stuart@gentoo.org> bugzilla-2.17.6-r2.ebuild:
+ Attempted(!!) fix for mysql password problem; see bug #46436
17 Apr 2004; Stuart Herbert <stuart@gentoo.org> bugzilla-2.17.6-r1.ebuild:
Fix for bug #48026
diff --git a/net-www/bugzilla/Manifest b/net-www/bugzilla/Manifest
index 2e26987ad525..5ada39a38295 100644
--- a/net-www/bugzilla/Manifest
+++ b/net-www/bugzilla/Manifest
@@ -1,6 +1,7 @@
MD5 5ee5cdee61d1ec65cb397f1ac5fb5590 bugzilla-2.17.6-r1.ebuild 4460
-MD5 2f716533d9a86bc0d9557734592a7fbd ChangeLog 745
+MD5 82bdeeef1961a86577514c173de514af ChangeLog 921
MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
+MD5 8526ee045c43070b2a96572be2510aa9 bugzilla-2.17.6-r2.ebuild 4310
MD5 0606a9da89d19a505c52818d14de61e3 files/cronset.sh 70
MD5 b38d67b03726b84833bd8c5f632e4020 files/bugzilla.cron.tab 54
MD5 8a1339d54a8d4525959a5d398300e7ee files/bz.cfg.templ 323
@@ -8,3 +9,4 @@ MD5 a001fc92584de0cd6f1a0d8de99ee6ce files/firstcheck.sh 48
MD5 4a9b1a263f16b2a53b44bce45350b373 files/bugzilla.conf 148
MD5 0be5a588dc7fdfc9e4898a855bd32361 files/bugzilla.cron.daily 115
MD5 3e92270cf32fdc56568c03aa92c5488d files/digest-bugzilla-2.17.6-r1 68
+MD5 3e92270cf32fdc56568c03aa92c5488d files/digest-bugzilla-2.17.6-r2 68
diff --git a/net-www/bugzilla/bugzilla-2.17.6-r2.ebuild b/net-www/bugzilla/bugzilla-2.17.6-r2.ebuild
new file mode 100644
index 000000000000..2d29ef762399
--- /dev/null
+++ b/net-www/bugzilla/bugzilla-2.17.6-r2.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+IUSE="apache2"
+
+# See http://www.bugzilla.org/docs216/html/stepbystep.html to verify dependancies
+DEPEND=">=dev-db/mysql-3.22.5
+ >=dev-lang/perl-5.01
+ >=dev-perl/AppConfig-1.52
+ dev-perl/Template-Toolkit
+ >=dev-perl/Text-Tabs+Wrap-2001.0131
+ >=dev-perl/File-Spec-0.8.2
+ >=dev-perl/DBD-mysql-1.2209
+ >=dev-perl/DBI-1.13
+ dev-perl/TimeDate
+ >=dev-perl/CGI-2.88
+ >=dev-perl/GD-1.19
+ dev-perl/GDGraph
+ >=dev-perl/Chart-0.99c
+ dev-perl/XML-Parser
+ dev-perl/MIME-tools
+ net-www/apache"
+
+# removed deps: dev-perl/Data-Dumper
+
+src_compile() {
+ :;
+}
+
+src_install () {
+ if use apache2 ; then
+ dodir /usr/bonsaitools/bin /etc/apache2/conf
+ else
+ dodir /usr/bonsaitools/bin /etc/apache/conf
+ fi
+
+ cd ${S}
+
+ # Bugzilla originally needs perl to be installed in /usr/bonsaitools/bin
+ # So let's change it for /usr/bin/perl
+ perl -pi -e 's@#\!/usr/bonsaitools/bin/perl@#\!/usr/bin/perl@' *cgi *pl Bug.pm || die
+ # syncshadowdb is gone
+ # Copy files to /var/www/bugzilla
+ insinto /var/www/bugzilla
+
+# doins * doesn't work recursively
+ cp -r ${S}/* ${D}/var/www/bugzilla || die
+# htdocs is for common apache docs, while bugzilla is a web app
+# So, it's better to keep it outside
+
+ if use apache2 ; then
+ cp ${FILESDIR}/bugzilla.conf ${D}/etc/apache2/conf || die
+ else
+ cp ${FILESDIR}/bugzilla.conf ${D}/etc/apache/conf || die
+ fi
+
+ cp ${FILESDIR}/bugzilla.cron.* ${D}/var/www/bugzilla || die
+ cp ${FILESDIR}/bz.cfg.templ ${D}/var/www/bugzilla || die
+ cp ${FILESDIR}/firstcheck.sh ${D}/var/www/bugzilla || die
+ cp ${FILESDIR}/cronset.sh ${D}/var/www/bugzilla || die
+ chown -R apache:apache ${D}/var/www/bugzilla || die
+}
+
+pkg_config() {
+ # moved here as it doesn't work in a sandbox
+ cd /var/www/bugzilla || die
+ if ( test -a localconfig ) ; then
+ die "The following does not work on previous installations, please run checksetup.pl in /var/www/bugzilla followed by a chown -R apache:apache /var/www/bugzilla."
+ fi
+
+ einfo "Finalizing the installation of bugzilla in /var/www/bugzilla"
+
+ echo -n "mysql bugs db name [bugs]: "; read mybugsdb
+ if (test -z $mybugsdb) ; then mybugsdb="bugs" ; fi
+
+ echo -n "mysql bugs db host [localhost]: "; read mybugshost
+ if (test -z $mybugshost) ; then mybugshost="localhost" ; fi
+
+ echo -n "mysql bugs dbuser name [bugs]: "; read mybugsuser
+ if (test -z $mybugsuser) ; then mybugsuser="bugs" ; fi
+
+ echo -n "mysql bugs dbuser password: "; read mybugspwd
+ if (test -z $mybugspwd) ; then eerror "No dbuser password" ; die ; fi
+
+ cat bz.cfg.templ | sed -e "s/tmpdbname/${mybugsdb}/" > bz.cfg.templ.1
+ cat bz.cfg.templ.1 | sed -e "s/tmphost/${mybugshost}/" > bz.cfg.templ.2
+ cat bz.cfg.templ.2 | sed -e "s/tmpdbuser/${mybugsuser}/" > bz.cfg.templ.3
+ cat bz.cfg.templ.3 | sed -e "s/tmpdbpass/${mybugspwd}/" > bz.cfg.pl
+
+ if [ ! -f bz.cfg.pl ] ; then eerror "No template for db vars" ; die ; fi
+
+ rm bz.cfg.templ.[0-9]* || die
+
+ einfo "Setting correct privelegies"
+ mysql -p mysql --exec="GRANT SELECT,INSERT,UPDATE,DELETE,INDEX, ALTER,CREATE,DROP,REFERENCES ON ${mybugsdb}.* TO ${mybugsuser}@${mybugshost} IDENTIFIED BY '${mybugspwd}'; FLUSH PRIVILEGES;" || die
+
+ einfo "Setting the template for localconfig variables"
+ ./checksetup.pl bz.cfg.pl || die
+ chown -R apache:apache /var/www/bugzilla || die
+
+ einfo "Final step: setting all html templates and db tables"
+ chmod 750 /var/www/bugzilla/firstcheck.sh
+ ./firstcheck.sh || die
+
+ echo -n "Do you want to set a crontab [y/N]" ; read cronyes
+ chmod 750 /var/www/bugzilla/cronset.sh
+ if ( test $cronyes = "y") ; then su - apache -c /var/www/bugzilla/cronset.sh ; fi
+
+ chown -R apache:apache /var/www/bugzilla || die
+
+ einfo "Then you just have to :"
+ einfo "append to apache/conf: Include conf/bugzilla.conf"
+ einfo "Restart Apache"
+ einfo "login on http://yourhost/bugzilla/index.cgi and edit global parameters click *parameters* at the bottom"
+ einfo "enjoy bugzilla!"
+
+}
+
+pkg_postinst() {
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ }
diff --git a/net-www/bugzilla/files/digest-bugzilla-2.17.6-r2 b/net-www/bugzilla/files/digest-bugzilla-2.17.6-r2
new file mode 100644
index 000000000000..bf009c3e8f1f
--- /dev/null
+++ b/net-www/bugzilla/files/digest-bugzilla-2.17.6-r2
@@ -0,0 +1 @@
+MD5 1fd6bdcd18838d54f54b30eeaa7d14ce bugzilla-2.17.6.tar.gz 1226064