summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2004-05-30 13:37:31 +0000
committerHanno Boeck <hanno@gentoo.org>2004-05-30 13:37:31 +0000
commit9f7875fef5e902ee0a91a8ae20b7ad0ab149f7fb (patch)
treea16b4a3806dac08c43eca6cde1fd8c55555c4a70 /net-www/galeon/galeon-1.3.14a.ebuild
parentadded gcc 3.4 fix. thanks to Malcolm Lashley for submitting it. (diff)
downloadhistorical-9f7875fef5e902ee0a91a8ae20b7ad0ab149f7fb.tar.gz
historical-9f7875fef5e902ee0a91a8ae20b7ad0ab149f7fb.tar.bz2
historical-9f7875fef5e902ee0a91a8ae20b7ad0ab149f7fb.zip
various small galeon fixes
Diffstat (limited to 'net-www/galeon/galeon-1.3.14a.ebuild')
-rw-r--r--net-www/galeon/galeon-1.3.14a.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-www/galeon/galeon-1.3.14a.ebuild b/net-www/galeon/galeon-1.3.14a.ebuild
index 1fb201c527d9..8231ce79bf60 100644
--- a/net-www/galeon/galeon-1.3.14a.ebuild
+++ b/net-www/galeon/galeon-1.3.14a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.3.14a.ebuild,v 1.1 2004/03/28 14:46:25 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.3.14a.ebuild,v 1.2 2004/05/30 13:37:31 hanno Exp $
inherit gnome2 debug libtool
@@ -11,7 +11,7 @@ RESTRICT="nomirror"
IUSE=""
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc ~ia64 ~amd64"
+KEYWORDS="x86 ~ppc ~alpha ~sparc ~ia64 ~amd64"
SLOT="0"
S=${WORKDIR}/${P%%a}
@@ -45,6 +45,11 @@ pkg_setup () {
fi
}
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/galeon-gcc34-fix.gz
+}
+
src_compile() {
# even when we have the XML-Parser module there may be a version mismatch
# this line will force the use of local intltool when compiling, avoiding mismatch
@@ -54,6 +59,10 @@ src_compile() {
elibtoolize
+ if [ `echo ${moz_ver} | grep 1.7rc` ]
+ then
+ moz_ver="trunk"
+ fi
local moz_ver="`pkg-config --modversion mozilla-xpcom | cut -d. -f1,2 2>/dev/null`"
local myconf="--disable-werror"