summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-07-23 06:05:16 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-07-23 06:05:16 +0000
commit81a412cab8e0e28992d901eaac5ec5af9e2d97ed (patch)
tree9b9a2aedb91881fc3200444875820b6cc45b7dd6 /net-www/jboss
parent(no commit message) (diff)
downloadhistorical-81a412cab8e0e28992d901eaac5ec5af9e2d97ed.tar.gz
historical-81a412cab8e0e28992d901eaac5ec5af9e2d97ed.tar.bz2
historical-81a412cab8e0e28992d901eaac5ec5af9e2d97ed.zip
*** empty log message ***
Diffstat (limited to 'net-www/jboss')
-rw-r--r--net-www/jboss/ChangeLog7
-rw-r--r--net-www/jboss/files/3.2.5/conf.d/jboss18
-rw-r--r--net-www/jboss/jboss-3.2.5.ebuild8
3 files changed, 25 insertions, 8 deletions
diff --git a/net-www/jboss/ChangeLog b/net-www/jboss/ChangeLog
index adf41240684e..6ce5e13f6a5d 100644
--- a/net-www/jboss/ChangeLog
+++ b/net-www/jboss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/jboss
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/jboss/ChangeLog,v 1.21 2004/07/20 20:23:10 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/jboss/ChangeLog,v 1.22 2004/07/23 06:05:16 mkennedy Exp $
+
+ 23 Jul 2004; <mkennedy@gentoo.org> files/3.2.5/conf.d/jboss,
+ jboss-3.2.5.ebuild:
+ Corrected Tomcat path problems with bandaid solution; Unmasking for previously
+ unmasked architectures.
20 Jul 2004; <mkennedy@gentoo.org> jboss-3.2.5.ebuild:
Configuration problem with Tomcat/Catalina/Ant and /var/lib/jboss causes JSP
diff --git a/net-www/jboss/files/3.2.5/conf.d/jboss b/net-www/jboss/files/3.2.5/conf.d/jboss
index 9147dbf054c8..248afc0b2802 100644
--- a/net-www/jboss/files/3.2.5/conf.d/jboss
+++ b/net-www/jboss/files/3.2.5/conf.d/jboss
@@ -1,5 +1,15 @@
# -*- mode: shell-script; mode: outline-minor; outline-regexp: "##+"; indent-tabs-mode: nil -*-
+## NOTES
+
+# This configuration file is based on the options enumerated in the
+# JBoss source code at:
+#
+# jboss-x.y.z-src/system/src/main/org/jboss/system/server/ServerConfig
+#
+# You may chose to add additional settings from there to this file.
+# We present a basic subset by default.
+
## GENERAL SETTINGS
# You can choose which configuration you want to run JBoss with. The
@@ -44,22 +54,20 @@ SERVER_SETTINGS="${SERVER_SETTINGS} -Djboss.server.data.dir=/var/cache/jboss"
SERVER_HOME="/var/lib/jboss"
SERVER_SETTINGS="${SERVER_SETTINGS} -Djboss.server.base.url=file://${SERVER_HOME}"
-# Whether or not the server should exit the JVM on shutdown (comment
-# out to disable)
+# Whether or not the server should exit the JVM on shutdown
-# SERVER_SETTINGS="${SERVER_SETTINGS} -Djboss.server.exitonshutdown"
+SERVER_SETTINGS="${SERVER_SETTINGS} -Djboss.server.exitonshutdown=true"
# Whether or not the server should shutdown synchronously (true) or
# asynchronously (false).
-SERVER_SETTINGS="${SERVER_SETTINGS} -Djboss.server.exitonshutdown=false"
+SERVER_SETTINGS="${SERVER_SETTINGS} -Djboss.server.blockingshutdown=true"
# The address JBoss will bind services to. (Note: JBoss 3.2.3 ignores
# the JVM environment parameter in favour of the command line switch.)
JBOSS_BIND_ADDRESS="0.0.0.0"
-
## STARTUP/SHUTDOWN CONFIGURATION
# Commands used in starting/stopping the server. Normally you would
diff --git a/net-www/jboss/jboss-3.2.5.ebuild b/net-www/jboss/jboss-3.2.5.ebuild
index 7c42c5ca9c6a..8e094044f375 100644
--- a/net-www/jboss/jboss-3.2.5.ebuild
+++ b/net-www/jboss/jboss-3.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/jboss/jboss-3.2.5.ebuild,v 1.2 2004/07/20 20:23:10 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/jboss/jboss-3.2.5.ebuild,v 1.3 2004/07/23 06:05:16 mkennedy Exp $
inherit eutils
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.jboss.org"
LICENSE="LGPL-2"
IUSE="doc"
SLOT="0"
-KEYWORDS="-*"
+KEYWORDS="~x86 ~ppc ~sparc"
RDEPEND=">=virtual/jdk-1.3"
DEPEND="${RDEPEND}
@@ -87,6 +87,10 @@ EOF
keepdir /var/log/jboss
keepdir /var/tmp/jboss
keepdir /var/cache/jboss
+
+ # the following hack is included until we determine how to make
+ # Catalina believe it lives in /var/lib/jboss/$JBOSS_CONF.
+ dosym /var/lib/jboss /usr/share/jboss/server
}
without_error() {