summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-07-06 00:59:13 +0000
committerChuck Short <zul@gentoo.org>2004-07-06 00:59:13 +0000
commitd2cd172064100a80d14a29abfd36098d9cdb3817 (patch)
treed8a21289893cb8b4ff54ed01f165fcbb63a77f93 /net-www/mod_random/mod_random-1.4.ebuild
parentre-keyword (diff)
downloadhistorical-d2cd172064100a80d14a29abfd36098d9cdb3817.tar.gz
historical-d2cd172064100a80d14a29abfd36098d9cdb3817.tar.bz2
historical-d2cd172064100a80d14a29abfd36098d9cdb3817.zip
Added mod_random for apache1.
Diffstat (limited to 'net-www/mod_random/mod_random-1.4.ebuild')
-rw-r--r--net-www/mod_random/mod_random-1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-www/mod_random/mod_random-1.4.ebuild b/net-www/mod_random/mod_random-1.4.ebuild
new file mode 100644
index 000000000000..adc7c58c237e
--- /dev/null
+++ b/net-www/mod_random/mod_random-1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_random/mod_random-1.4.ebuild,v 1.1 2004/07/06 00:59:13 zul Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache DSO providing custom randomized responses"
+HOMEPAGE="http://software.tangent.org/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+DEPEND="=net-www/apache-1*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+
+src_compile() {
+ apxs -c ${PN}.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache/conf/modules.d
+ doins ${FILESDIR}/17_mod_random.conf
+ dodoc ${FILESDIR}/17_mod_random.conf
+ dodoc ChangeLog INSTALL LICENSE README VERSION
+ dohtml *.html
+}