summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-12 04:42:02 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-12 04:42:02 +0000
commita6081963aefc48deaaf6d73ae9e7f6ad203f112f (patch)
tree07fed8cf6fc75268be924a77b5433d02f4c7185e /net-www/mod_scgi
parentNew package (diff)
downloadhistorical-a6081963aefc48deaaf6d73ae9e7f6ad203f112f.tar.gz
historical-a6081963aefc48deaaf6d73ae9e7f6ad203f112f.tar.bz2
historical-a6081963aefc48deaaf6d73ae9e7f6ad203f112f.zip
New package
Diffstat (limited to 'net-www/mod_scgi')
-rw-r--r--net-www/mod_scgi/Manifest5
-rw-r--r--net-www/mod_scgi/files/20_mod_scgi.conf5
-rw-r--r--net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha11
-rw-r--r--net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild47
4 files changed, 56 insertions, 2 deletions
diff --git a/net-www/mod_scgi/Manifest b/net-www/mod_scgi/Manifest
index df6afa173985..5fa635679ccb 100644
--- a/net-www/mod_scgi/Manifest
+++ b/net-www/mod_scgi/Manifest
@@ -1,3 +1,4 @@
-MD5 6895fc0d9d65c0a2c65f01ec0fc645d6 .mod_scgi-1.2_alpha1.ebuild.swp 12288
-MD5 0f200994a1d5098336cb0baab84f5c93 mod_scgi-1.2_alpha1.ebuild 812
+MD5 c88cc1e17740d8b35139af7a915341a1 mod_scgi-1.2_alpha1.ebuild 1214
+MD5 094b07f31ed336f5bf553ca221162686 ChangeLog 349
MD5 fe6e3027503038b59f1e9b4ee2cb3baa files/digest-mod_scgi-1.2_alpha1 61
+MD5 3d1c20f03676d9a3da3d0fe3ea73720f files/20_mod_scgi.conf 118
diff --git a/net-www/mod_scgi/files/20_mod_scgi.conf b/net-www/mod_scgi/files/20_mod_scgi.conf
new file mode 100644
index 000000000000..126feefd3357
--- /dev/null
+++ b/net-www/mod_scgi/files/20_mod_scgi.conf
@@ -0,0 +1,5 @@
+<IfDefine MODSCGI>
+ <IfModule !mod_scgi.c>
+ LoadModule scgi_module extramodules/mod_scgi.so
+ <!IfModule>
+</IfDefine>
diff --git a/net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha1 b/net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha1
new file mode 100644
index 000000000000..818dbd4658ba
--- /dev/null
+++ b/net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha1
@@ -0,0 +1 @@
+MD5 2bb8b05c3f771c25778c808ab0960580 scgi-1.2a1.tar.gz 17778
diff --git a/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild b/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild
new file mode 100644
index 000000000000..926c16cc09f2
--- /dev/null
+++ b/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild,v 1.1 2003/08/12 04:40:48 g2boojum Exp $
+
+P0=${P/mod_/}
+MY_P=${P0/_alpha/a}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Apache module for a Replacement for the CGI protocol that is similar to FastCGI"
+HOMEPAGE="http://www.mems-exchange.org/software/scgi/"
+SRC_URI="http://www.mems-exchange.org/software/files/${PN}/${MY_P}.tar.gz"
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="apache2"
+DEPEND="net-www/scgi
+ net-www/apache
+ apache2? ( >=net-www/apache-2 )"
+
+src_compile() {
+ if [ -z "`use apache2`" ]
+ then
+ cd apache1
+ make || die "apache1 mod_scgi make failed"
+ else
+ cd apache2
+ make || die "apache2 mod_scgi make failed"
+ fi
+}
+
+src_install() {
+ if [ -z "`use apache2`" ]
+ then
+ cd apache1
+ exeinto /usr/lib/apache-extramodules
+ doexe .libs/${PN}.so
+ dodoc README
+ insinto /etc/apache/conf/modules.d
+ doins ${FILESDIR}/20_mod_scgi.conf
+ else
+ cd apache2
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ dodoc README
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/20_mod_scgi.conf
+ fi
+}