summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-27 00:10:52 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-27 00:10:52 +0000
commit82d5e0ecfa31c744b040f47688d5e1c2e92700eb (patch)
tree4c1963411bf8d8f5ba3f5578746cb7410919ae0a /net-www/mod_ssl
parentVersion bump. (diff)
downloadhistorical-82d5e0ecfa31c744b040f47688d5e1c2e92700eb.tar.gz
historical-82d5e0ecfa31c744b040f47688d5e1c2e92700eb.tar.bz2
historical-82d5e0ecfa31c744b040f47688d5e1c2e92700eb.zip
Security update
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.121
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.12.ebuild75
3 files changed, 82 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index b5c8d609af56..b4f391419cce 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.7 2002/10/10 19:38:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.8 2002/10/27 00:10:52 aliz Exp $
+
+*mod_ssl-2.8.12 (26 Oct 2002)
+
+ 26 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
*mod_ssl-2.8.11.ebuild (14 July 2002)
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.12 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.12
new file mode 100644
index 000000000000..dfab8708a5e4
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.12
@@ -0,0 +1 @@
+MD5 6d52df71a602ae150898fb8483fa22a4 mod_ssl-2.8.12-1.3.27.tar.gz 753529
diff --git a/net-www/mod_ssl/mod_ssl-2.8.12.ebuild b/net-www/mod_ssl/mod_ssl-2.8.12.ebuild
new file mode 100644
index 000000000000..1bed5a95e1f6
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.12.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.12.ebuild,v 1.1 2002/10/27 00:10:52 aliz Exp $
+
+MY_P=${P}-1.3.27
+
+DESCRIPTION="An SSL module for the Apache Web server"
+HOMEPAGE="http://www.modssl.org"
+KEYWORDS="x86 ppc sparc sparc64"
+
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+
+DEPEND="virtual/glibc =net-www/apache-1.3.27* >=dev-libs/openssl-0.9.6c"
+LICENSE="as-is"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ mkdir -p ${D}/usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}