summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-07-29 20:08:23 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-07-29 20:08:23 +0000
commitceedcdc6c1479758a3681d2e8d3b1195349f4185 (patch)
tree5b00e9d9377d62368c4fb4b69f69d1a6ec6159c6 /net-www/mod_ssl
parentppc stable, bug #141842 (diff)
downloadhistorical-ceedcdc6c1479758a3681d2e8d3b1195349f4185.tar.gz
historical-ceedcdc6c1479758a3681d2e8d3b1195349f4185.tar.bz2
historical-ceedcdc6c1479758a3681d2e8d3b1195349f4185.zip
Bump version, bug 141986.
Package-Manager: portage-2.1.1_pre4
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.283
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.28.ebuild75
3 files changed, 84 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index 807e5aca878f..2da4b74bf0a7 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.109 2006/06/05 03:22:38 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.110 2006/07/29 20:04:34 kloeri Exp $
+
+*mod_ssl-2.8.28 (29 Jul 2006)
+
+ 29 Jul 2006; Bryan Østergaard <kloeri@gentoo.org> +mod_ssl-2.8.28.ebuild:
+ Bump version, bug 141986.
05 Jun 2006; Michael Stewart <vericgar@gentoo.org> -mod_ssl-2.8.21.ebuild,
-mod_ssl-2.8.22.ebuild, -mod_ssl-2.8.22-r1.ebuild, -mod_ssl-2.8.24.ebuild,
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.28 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.28
new file mode 100644
index 000000000000..7b48f2a3160d
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.28
@@ -0,0 +1,3 @@
+MD5 5e9486a86fcd4efef395f58fd795aaea mod_ssl-2.8.28-1.3.37.tar.gz 820417
+RMD160 6b12c0a52fe0fbb7b91221d1cb37f93fbe59bb11 mod_ssl-2.8.28-1.3.37.tar.gz 820417
+SHA256 76437105b5b5593a7dbd8ee45af417233897dcaf910cbc337a68b0db24e35489 mod_ssl-2.8.28-1.3.37.tar.gz 820417
diff --git a/net-www/mod_ssl/mod_ssl-2.8.28.ebuild b/net-www/mod_ssl/mod_ssl-2.8.28.ebuild
new file mode 100644
index 000000000000..dd292d7bec00
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.28.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.28.ebuild,v 1.1 2006/07/29 20:04:34 kloeri Exp $
+
+inherit apache-module
+
+MY_P=${P}-1.3.37
+
+DESCRIPTION="An SSL module for the Apache 1.3 Web server"
+HOMEPAGE="http://www.modssl.org/"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.6k"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+APACHE1_MOD_FILE="${S}/pkg.sslmod/libssl.so"
+APACHE1_MOD_CONF="10_${PN}"
+APACHE1_MOD_DEFINE="SSL"
+
+VHOSTFILE="default-ssl"
+
+DOCFILES="ANNOUNCE CHANGES CREDITS LICENSE NEWS README*"
+
+need_apache1
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+
+ # proper path to openssl
+ sed -i -e 's:^\(openssl=\).*:\1"/usr/bin/openssl":' pkg.contrib/cca.sh
+}
+
+src_compile() {
+ if has_version '=sys-libs/gdbm-1.8.3*' ; then
+ myconf="--enable-rule=SSL_SDBM"
+ fi
+
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=${APXS1} ${myconf} || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ apache1_src_install
+
+ insinto ${APACHE1_VHOSTDIR}
+ doins ${FILESDIR}/${VHOSTFILE}.conf
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodir /usr/share/doc/${PF}/html
+ cp -pPR pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}${APACHE1_CONFDIR}/ssl
+
+ apache1_pkg_postinst
+
+ cd ${ROOT}${APACHE1_CONFDIR}/ssl
+ einfo "Generating self-signed test certificate in ${APACHE1_CONFDIR}/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}