summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-08-01 22:59:37 +0000
committerMichael Imhof <tantive@gentoo.org>2003-08-01 22:59:37 +0000
commit18fe5bebaf58ff83795cbbd2b04940297970d687 (patch)
tree91d83a535e3ea37311251cf513195c7fc42d8772 /net-www/pound
parentInitial import. Should close #19207. (diff)
downloadhistorical-18fe5bebaf58ff83795cbbd2b04940297970d687.tar.gz
historical-18fe5bebaf58ff83795cbbd2b04940297970d687.tar.bz2
historical-18fe5bebaf58ff83795cbbd2b04940297970d687.zip
Initial import. Should close #19207.
Diffstat (limited to 'net-www/pound')
-rw-r--r--net-www/pound/Manifest6
-rw-r--r--net-www/pound/files/digest-pound-1.41
-rw-r--r--net-www/pound/files/pound.cfg41
-rw-r--r--net-www/pound/files/pound.init24
-rw-r--r--net-www/pound/pound-1.4.ebuild60
5 files changed, 129 insertions, 3 deletions
diff --git a/net-www/pound/Manifest b/net-www/pound/Manifest
index f2ade1a935c3..4f3eaafbffd4 100644
--- a/net-www/pound/Manifest
+++ b/net-www/pound/Manifest
@@ -1,5 +1,5 @@
-MD5 0280dca640205746fe5b8fd0380943aa ChangeLog 312
-MD5 a21ee40a04287e5d17e0b44e07237265 pound-1.4.ebuild 1274
+MD5 a6a6fe4754c102183ffc0ddb378530e6 ChangeLog 399
+MD5 8aa32a79e99ccb7bd6cde0b272273ef5 pound-1.4.ebuild 1367
MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
-MD5 33614bbdeb693f025d295a8f82be17da files/pound.init 539
+MD5 2e471aa35129f6523583abbd87084bc5 files/pound.init 633
MD5 ea7096804d2dc2e498de690fa440821d files/digest-pound-1.4 58
diff --git a/net-www/pound/files/digest-pound-1.4 b/net-www/pound/files/digest-pound-1.4
new file mode 100644
index 000000000000..7b5a36a2d4ae
--- /dev/null
+++ b/net-www/pound/files/digest-pound-1.4
@@ -0,0 +1 @@
+MD5 23a4634b0f9b964ede58f5e49a30ff7e Pound-1.4.tgz 115859
diff --git a/net-www/pound/files/pound.cfg b/net-www/pound/files/pound.cfg
new file mode 100644
index 000000000000..482be9b79162
--- /dev/null
+++ b/net-www/pound/files/pound.cfg
@@ -0,0 +1,41 @@
+## Minimal sample pound.cfg
+##
+## see pound(8) for details
+
+
+######################################################################
+## global options:
+
+User nobody
+Group nobody
+#RootJail /chroot/pound
+
+## allow PUT and DELETE also (by default only GET, POST and HEAD)?:
+ExtendedHTTP 0
+
+WebDAV 0
+
+## Logging: (goes to syslog by default)
+## 0 no logging
+## 1 normal
+## 2 extended
+## 3 Apache-style (common log format)
+LogLevel 1
+
+## check backend every X secs:
+Alive 30
+
+## use hardware-accelleration card supported by openssl(1):
+#SSLEngine <hw>
+
+
+######################################################################
+## listen, redirect and ... to:
+
+## redirect all requests on port 8888 ("ListenHTTP") to the local webserver see "UrlGroup" below):
+ListenHTTP 127.0.0.1,8888
+
+##
+UrlGroup ".*"
+BackEnd 127.0.0.1,80,1
+EndGroup
diff --git a/net-www/pound/files/pound.init b/net-www/pound/files/pound.init
new file mode 100644
index 000000000000..6c45e59d57a2
--- /dev/null
+++ b/net-www/pound/files/pound.init
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/files/pound.init,v 1.1 2003/08/01 22:59:20 tantive Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting pound"
+ if [ ! -f "/etc/pound.cfg" ]; then
+ eend 1 "configfile /etc/pound.cfg not found."
+ fi
+ start-stop-daemon --quiet --start --startas /usr/sbin/pound \
+ --pidfile /var/run/pound.pid -- -f /etc/pound.cfg
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pound"
+ start-stop-daemon --quiet --stop --pidfile /var/run/pound.pid
+ eend $?
+}
diff --git a/net-www/pound/pound-1.4.ebuild b/net-www/pound/pound-1.4.ebuild
new file mode 100644
index 000000000000..a1ac92409da0
--- /dev/null
+++ b/net-www/pound/pound-1.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/pound-1.4.ebuild,v 1.1 2003/08/01 22:59:20 tantive Exp $
+
+MY_P=${P/p/P}
+
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc ~alpha ~mips ~hppa"
+IUSE="ssl"
+
+DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ ## check for ssl-support:
+ if [ "$(use ssl)" ]; then
+ myconf="${myconf} --with-ssl"
+ else
+ myconf="${myconf} --without-ssl"
+ fi
+
+ ## TODO: how to handle the missing "syslog" USE-flag?
+ ## check for syslog-support:
+ #if [ "$(use syslog)" ]; then
+ # myconf="${myconf} --with-log="
+ #else
+ # myconf="${myconf} --without-log"
+ #fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ dosbin pound
+ doman pound.8
+
+ dodoc README
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pound.init pound
+
+ insinto /etc
+ doins ${FILESDIR}/pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+}