summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-04-08 21:43:01 +0000
committerDean Bailey <alron@gentoo.org>2003-04-08 21:43:01 +0000
commit79a9f1c50be5d4ff75da22337cb74ab0b4ca5322 (patch)
tree5d646572cf735ecaa10cd49308022b755a5b399a /net-www
parentsparc keyword (diff)
downloadhistorical-79a9f1c50be5d4ff75da22337cb74ab0b4ca5322.tar.gz
historical-79a9f1c50be5d4ff75da22337cb74ab0b4ca5322.tar.bz2
historical-79a9f1c50be5d4ff75da22337cb74ab0b4ca5322.zip
updated
Diffstat (limited to 'net-www')
-rw-r--r--net-www/horde-imp/ChangeLog6
-rw-r--r--net-www/horde-imp/files/digest-horde-imp-3.2.11
-rw-r--r--net-www/horde-imp/horde-imp-3.2.1.ebuild71
3 files changed, 77 insertions, 1 deletions
diff --git a/net-www/horde-imp/ChangeLog b/net-www/horde-imp/ChangeLog
index 3281fd6ca5c5..5e87501adb81 100644
--- a/net-www/horde-imp/ChangeLog
+++ b/net-www/horde-imp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/horde-imp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/ChangeLog,v 1.9 2003/02/24 20:27:08 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/ChangeLog,v 1.10 2003/04/08 21:43:01 alron Exp $
+
+*horde-imp-3.2.1 (08 Apr 2003)
+ 08 Apr 2003; Dean Bailey <alron@gentoo.org> horde-imp-3.2.1 :
+ Version bump to 3.2.1, added dep on horde-pear
*horde-imp-3.2 (24 Feb 2003)
24 Feb 2003; Dean Bailey <alron@gentoo.org> horde-imp-3.2 :
diff --git a/net-www/horde-imp/files/digest-horde-imp-3.2.1 b/net-www/horde-imp/files/digest-horde-imp-3.2.1
new file mode 100644
index 000000000000..d12d5c1bd5c4
--- /dev/null
+++ b/net-www/horde-imp/files/digest-horde-imp-3.2.1
@@ -0,0 +1 @@
+MD5 0ab8edfcd1439e52b0f29e84fef0cf54 imp-3.2.1.tar.gz 1312731
diff --git a/net-www/horde-imp/horde-imp-3.2.1.ebuild b/net-www/horde-imp/horde-imp-3.2.1.ebuild
new file mode 100644
index 000000000000..883e1ba58c6a
--- /dev/null
+++ b/net-www/horde-imp/horde-imp-3.2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-imp/horde-imp-3.2.1.ebuild,v 1.1 2003/04/08 21:43:01 alron Exp $
+
+DESCRIPTION="IMP ${PV} provides webmail access"
+HOMEPAGE="http://www.horde.org"
+P=imp-3.2.1
+SRC_URI="ftp://ftp.horde.org/pub/imp/tarballs/imp-3.2.1.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2.1"
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep imap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREP}" != "" ]; then
+ return 0
+ else
+ eerror "Missing IMAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ # FIXME: With time, apache's GID should be static
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+
+ dodir ${HTTPD_ROOT}/horde/imp
+ cp -r . ${D}/${HTTPD_ROOT}/horde/imp
+
+ # protecting files
+ chown -R root.${GID} ${D}/${HTTPD_ROOT}/horde/imp
+ find ${D}/${HTTPD_ROOT}/horde/imp/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/imp/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+
+ find_http_root
+
+ einfo "Please read ${HTTPD_ROOT}/horde/imp/docs/INSTALL !"
+}