summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2003-06-08 17:12:40 +0000
committerBrad Laue <brad@gentoo.org>2003-06-08 17:12:40 +0000
commit948d316cfb56f2a9cea9ac9f5204e50d011d1697 (patch)
treed75b15c5597fb09c193b61c898fbae7dc741ebfd /net-www
parentFilter some Pentium4 specifics if we're also filtering Pentium4 (diff)
downloadhistorical-948d316cfb56f2a9cea9ac9f5204e50d011d1697.tar.gz
historical-948d316cfb56f2a9cea9ac9f5204e50d011d1697.tar.bz2
historical-948d316cfb56f2a9cea9ac9f5204e50d011d1697.zip
Bring this ebuild up to speed with mozilla-firebird re: filtering pentium4 and msse2
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla-firebird-cvs/ChangeLog10
-rw-r--r--net-www/mozilla-firebird-cvs/Manifest4
-rw-r--r--net-www/mozilla-firebird-cvs/files/digest-mozilla-firebird-cvs-0.6-r10
-rw-r--r--net-www/mozilla-firebird-cvs/mozilla-firebird-cvs-0.6-r1.ebuild165
4 files changed, 176 insertions, 3 deletions
diff --git a/net-www/mozilla-firebird-cvs/ChangeLog b/net-www/mozilla-firebird-cvs/ChangeLog
index ff613485034b..4572bc88f671 100644
--- a/net-www/mozilla-firebird-cvs/ChangeLog
+++ b/net-www/mozilla-firebird-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/phoenix-cvs
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird-cvs/ChangeLog,v 1.1 2003/06/06 00:58:02 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird-cvs/ChangeLog,v 1.2 2003/06/08 17:12:33 brad Exp $
+
+*mozilla-firebird-cvs-0.6-r1 (08 Jun 2003)
+
+ 08 Jun 2003; Brad Laue <brad@gentoo.org> mozilla-firebird-cvs-0.6-r1.ebuild:
+ Strip -msse2 out of the build if this is a Pentium4 and we're using GCC 3.2.x.
+ Otherwise, build will fail with a messy assembly error.
*mozilla-firebird-cvs-0.6 (05 Jun 2003)
@@ -25,7 +31,7 @@
30 Mar 2003; phoen][x <phoenix@gentoo.org>; phoenix-cvs-0.5-r2.ebuild,
files/digest-phoenix-cvs-0.5-r2, files/phoenix:
Seth asked me to take a look into -r1. I cleaned up a few things:
- - Added the missing $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird-cvs/ChangeLog,v 1.1 2003/06/06 00:58:02 brad Exp $
+ - Added the missing $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird-cvs/ChangeLog,v 1.2 2003/06/08 17:12:33 brad Exp $
- made ebuild use flag-o-matic over ${CFLAGS//}
- made ebuild use nsplugins.eclass for easy plugin integration
TODO:
diff --git a/net-www/mozilla-firebird-cvs/Manifest b/net-www/mozilla-firebird-cvs/Manifest
index 44303d5349b1..0dbbfe48e981 100644
--- a/net-www/mozilla-firebird-cvs/Manifest
+++ b/net-www/mozilla-firebird-cvs/Manifest
@@ -1,4 +1,6 @@
+MD5 f2bc7c47bd27f33848f9e5d248404b7c ChangeLog 1871
MD5 863fcdff5c830486d7f964c8485159f2 mozilla-firebird-cvs-0.6.ebuild 4504
-MD5 d2a695afb4b1ca4c1d23c3a7836d190c ChangeLog 1608
+MD5 bb7b91898205e9999e17f21e750bc82b mozilla-firebird-cvs-0.6-r1.ebuild 4586
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-mozilla-firebird-cvs-0.6 0
MD5 8c4939880225843b71f61395fc754e14 files/MozillaFirebird 757
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-mozilla-firebird-cvs-0.6-r1 0
diff --git a/net-www/mozilla-firebird-cvs/files/digest-mozilla-firebird-cvs-0.6-r1 b/net-www/mozilla-firebird-cvs/files/digest-mozilla-firebird-cvs-0.6-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-www/mozilla-firebird-cvs/files/digest-mozilla-firebird-cvs-0.6-r1
diff --git a/net-www/mozilla-firebird-cvs/mozilla-firebird-cvs-0.6-r1.ebuild b/net-www/mozilla-firebird-cvs/mozilla-firebird-cvs-0.6-r1.ebuild
new file mode 100644
index 000000000000..15b8fff7b8dd
--- /dev/null
+++ b/net-www/mozilla-firebird-cvs/mozilla-firebird-cvs-0.6-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird-cvs/mozilla-firebird-cvs-0.6-r1.ebuild,v 1.1 2003/06/08 17:12:33 brad Exp $
+
+inherit makeedit flag-o-matic gcc nsplugins
+
+# Added to get phoenix to compile on sparc.
+replace-sparc64-flags
+
+EMVER="0.65.2"
+IPCVER="1.0.0.1"
+
+MY_PN=${PN/-cvs/}
+MY_PV1=${PV/_}
+MY_PV2=${MY_PV1/eta}
+S=${WORKDIR}/mozilla
+DESCRIPTION="The Mozilla Firebird Web Browser"
+HOMEPAGE="http://www.mozilla.org/projects/firebird/"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+LICENSE="MPL-1.1 | NPL-1.1"
+IUSE="java gtk2 ipv6"
+
+RDEPEND="virtual/x11
+ >=dev-libs/libIDL-0.8.0
+ >=gnome-base/ORBit-0.5.10-r1
+ virtual/xft
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ >=sys-apps/portage-2.0.36
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ ( gtk2? >=x11-libs/gtk+-2.1.1 :
+ =x11-libs/gtk+-1.2* )
+ java? ( virtual/jre )
+ !net-www/phoenix-bin"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ dev-lang/perl
+ dev-util/cvs
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+# needed by src_compile() and src_install()
+export MOZ_PHOENIX=1
+export MOZ_CALENDAR=0
+export MOZ_ENABLE_XFT=1
+
+src_unpack() {
+ # This is hackish, but it works.
+ addwrite ${DISTDIR}/cvs-src
+ mkdir -p ${DISTDIR}/cvs-src/
+ cd ${DISTDIR}/cvs-src/
+ echo ":pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot A" > "${T}/cvspass"
+ export CVS_PASSFILE="${T}/cvspass"
+ einfo "Checking out latest Mozilla from CVS..."
+ einfo "[ mozilla/browser & mozilla/toolkit ]"
+ cvs -z3 -d:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot checkout mozilla/browser mozilla/toolkit mozilla/client.mk
+ make -f mozilla/client.mk checkout
+ cp -a mozilla ${S}
+ # Fix an ownership porblem
+ chown -R root.root ${S}
+}
+
+src_compile() {
+ local myconf="--disable-composer \
+ --with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-mailnews \
+ --disable-calendar \
+ --enable-xft \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --enable-xinerama=no \
+ --with-java-supplement \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaFirebird \
+ --with-user-appdir=.phoenix \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --disable-ldap \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ filter-flags -msse2
+ fi
+
+ # Enable us to use flash, etc plugins compiled with gcc-2.95.3
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-old-abi-compat-wrappers"
+ fi
+ fi
+
+ econf ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_PHOENIX=1 || die
+}
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir /${PLUGIN_DIR}
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaFirebird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirebird
+
+ #fix permissions
+ chown -R root.root ${D}/usr/lib/MozillaFirebird
+
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /usr/lib/MozillaFirebird/plugins
+
+ dobin ${FILESDIR}/MozillaFirebird
+}
+
+pkg_preinst() {
+ # Remove the old plugins dir
+ pkg_mv_plugins /usr/lib/MozillaFirebird/plugins
+}