summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-03-23 17:50:06 +0000
committerTilman Klar <phoenix@gentoo.org>2003-03-23 17:50:06 +0000
commit9b16e5e2250f400d791f97963c0cb77debeed54c (patch)
treea66b1a765321425a9c6e640d2b70ab189cc03987 /net-www
parentHercules 2.17.1-r1 (diff)
downloadhistorical-9b16e5e2250f400d791f97963c0cb77debeed54c.tar.gz
historical-9b16e5e2250f400d791f97963c0cb77debeed54c.tar.bz2
historical-9b16e5e2250f400d791f97963c0cb77debeed54c.zip
Made ebuild use the nsplugins functions.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phoenix-bin/ChangeLog7
-rw-r--r--net-www/phoenix-bin/phoenix-bin-0.5.ebuild15
2 files changed, 11 insertions, 11 deletions
diff --git a/net-www/phoenix-bin/ChangeLog b/net-www/phoenix-bin/ChangeLog
index e09597940b2b..1b6923ad1860 100644
--- a/net-www/phoenix-bin/ChangeLog
+++ b/net-www/phoenix-bin/ChangeLog
@@ -1,16 +1,19 @@
# ChangeLog for net-www/phoenix-bin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/ChangeLog,v 1.19 2003/03/05 13:12:05 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/ChangeLog,v 1.20 2003/03/23 17:50:06 phoenix Exp $
*phoenix-bin-0.5 (30 Dec 2002)
+ 23 Mar 2003; phoen][x <phoenix@gentoo.org> phoenix-bin-0.5.ebuild :
+ Made the ebuild use the nsplugins functions.
+
05 Mar 2003; phoen][x <phoenix@gentoo.org> files/phoenix :
Modified the phoenix startup script (see bug #15202 for additional info).
Updated the gtk dependencies. See bug #13112 for further details.
Thanks to Max Kalika <alkern23@yahoo.com> for the contribution.
- 30 Dec 2002; Thomas Raschbacher <lordvan@gentoo.org> phoenix-bin-0.5.ebuild
+ 30 Dec 2002; Thomas Raschbacher <lordvan@gentoo.org> phoenix-bin-0.5.ebuild :
unmasked 0.5 for x86
*phoenix-bin-0.4-r2 (10 Dec 2002)
diff --git a/net-www/phoenix-bin/phoenix-bin-0.5.ebuild b/net-www/phoenix-bin/phoenix-bin-0.5.ebuild
index 631e12960f52..0f81f5349fba 100644
--- a/net-www/phoenix-bin/phoenix-bin-0.5.ebuild
+++ b/net-www/phoenix-bin/phoenix-bin-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/phoenix-bin-0.5.ebuild,v 1.4 2003/03/05 13:03:49 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/phoenix-bin-0.5.ebuild,v 1.5 2003/03/23 17:50:06 phoenix Exp $
IUSE=""
@@ -31,18 +31,15 @@ src_install() {
mv ${S} ${D}/usr/lib
# Plugin path setup (rescuing the existent plugins)
- mv ${D}/usr/lib/${MY_PN}/plugins ${D}/usr/lib/${MY_PN}/plugins.temp
- dosym ../nsbrowser/plugins /usr/lib/${MY_PN}/
- mv ${D}/usr/lib/${MY_PN}/plugins.temp/* ${D}/usr/lib/${MY_PN}/plugins/
- rmdir ${D}/usr/lib/${MY_PN}/plugins.temp
+ src_mv_plugins /usr/lib/${MY_PN}/plugins
# Fixing permissions
chown -R root.root ${D}/usr/lib/${MY_PN}
# Truetype fonts
- cd ${D}/usr/lib/${MY_PN}/defaults/pref
- einfo "Enabling truetype fonts"
- patch < ${FILESDIR}/phoenix-0.4-antialiasing-patch
+ cd ${D}/usr/lib/${MY_PN}/defaults/pref
+ einfo "Enabling truetype fonts"
+ patch < ${FILESDIR}/phoenix-0.4-antialiasing-patch
# Misc stuff
dobin ${FILESDIR}/phoenix
@@ -51,5 +48,5 @@ src_install() {
pkg_preinst() {
# Remove the old plugins dir
- [ -d /usr/lib/phoenix/plugins ] && rm -r /usr/lib/phoenix/plugins
+ pkg_mv_plugins /usr/lib/${MY_PN}/plugins
}