summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-03 21:43:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-03 21:43:21 +0000
commit11fc598033aaa828a3f295b243f881b66deda769 (patch)
tree31cd2ba3beb1148efe2428d18467c1df2ca00290 /net-zope/xron/xron-0.0.10.ebuild
parentinitial commit (diff)
downloadhistorical-11fc598033aaa828a3f295b243f881b66deda769.tar.gz
historical-11fc598033aaa828a3f295b243f881b66deda769.tar.bz2
historical-11fc598033aaa828a3f295b243f881b66deda769.zip
initial commit
Diffstat (limited to 'net-zope/xron/xron-0.0.10.ebuild')
-rw-r--r--net-zope/xron/xron-0.0.10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-zope/xron/xron-0.0.10.ebuild b/net-zope/xron/xron-0.0.10.ebuild
new file mode 100644
index 000000000000..814716b3e457
--- /dev/null
+++ b/net-zope/xron/xron-0.0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/xron/xron-0.0.10.ebuild,v 1.1 2003/10/03 21:43:20 robbat2 Exp $
+
+inherit zproduct
+
+MY_PN="${PN/xron/Xron}"
+MY_PV="${PV//./-}"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="Xron schedules and executes procedures for Zope applications"
+HOMEPAGE="http://www.zope.org/Members/lstaffor/Xron"
+SRC_URI="${HOMEPAGE}/${PV}/${MY_P}.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+ZPROD_LIST="Xron"
+MYDOC="${MYDOC} *.txt"
+
+src_install() {
+ zproduct_src_install
+ # fix permissions on files
+ DIR=${D}/usr/share/zproduct/${PF}
+ find ${DIR} -exec chown zope.root \{} \;
+ find ${DIR} -exec chmod 644 \{} \;
+ find ${DIR} -type d -exec chmod +x \{} \;
+}
+