summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-28 00:16:02 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-28 00:16:02 +0000
commitf4a09a9be33686c5edfebcdeeecada81ac1ce33e (patch)
tree4605aa767988e998af7388c5d1c0fc90ffe32b9f /sci-biology/diya
parentAutomated update of use.local.desc (diff)
downloadhistorical-f4a09a9be33686c5edfebcdeeecada81ac1ce33e.tar.gz
historical-f4a09a9be33686c5edfebcdeeecada81ac1ce33e.tar.bz2
historical-f4a09a9be33686c5edfebcdeeecada81ac1ce33e.zip
New package, ebuild written by me
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/diya')
-rw-r--r--sci-biology/diya/ChangeLog10
-rw-r--r--sci-biology/diya/Manifest4
-rw-r--r--sci-biology/diya/diya-1.0_rc4.ebuild43
-rw-r--r--sci-biology/diya/metadata.xml9
4 files changed, 66 insertions, 0 deletions
diff --git a/sci-biology/diya/ChangeLog b/sci-biology/diya/ChangeLog
new file mode 100644
index 000000000000..10a6db4f096d
--- /dev/null
+++ b/sci-biology/diya/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/diya
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/diya/ChangeLog,v 1.1 2009/09/28 00:16:02 weaver Exp $
+
+*diya-1.0_rc4 (27 Sep 2009)
+
+ 27 Sep 2009; Andrey Kislyuk <weaver@gentoo.org> +metadata.xml,
+ +diya-1.0_rc4.ebuild:
+ New package, ebuild written by me
+
diff --git a/sci-biology/diya/Manifest b/sci-biology/diya/Manifest
new file mode 100644
index 000000000000..c0eff7fc9634
--- /dev/null
+++ b/sci-biology/diya/Manifest
@@ -0,0 +1,4 @@
+DIST diya-1.0-rc4.tar.gz 386706 RMD160 1548c83b9e7130bd8dc8407f51ea7a50848499bd SHA1 90c9ad6f1cd69fe814b74eaa1cdbce56e34e74bb SHA256 13f7dd4dd7f96143948587884954e337552d7491347c2c174e786824880590c7
+EBUILD diya-1.0_rc4.ebuild 1355 RMD160 3e97919a99a7e56ff12a97ed0dc1440ea1c49c87 SHA1 2d6298d218b5a854094e6924e0a9e784d906f0bb SHA256 443c9c9e77f8d3bf1b16cc88c3ffb53a582d164b595f6a65eb941c6e44fa5db3
+MISC ChangeLog 360 RMD160 128ea0c392f91e2a45836cd8c02aebb57884259d SHA1 58f067012e5e6c8d1424f372e37554c14c7ee794 SHA256 81c3f06feb36d034eae1c7a846bfaea33e50a8d3b739ad637461cb85e520e8bf
+MISC metadata.xml 259 RMD160 d9d81b67d635fabd81aef8ae0edf971211ae9072 SHA1 8e32f751c67ff891fa35405a2cf6fb33752d6eb1 SHA256 541c3fbcf299d9a8ccf4132ee61f9e53a5d737cefdaa6fdc77764d8d4c7f3110
diff --git a/sci-biology/diya/diya-1.0_rc4.ebuild b/sci-biology/diya/diya-1.0_rc4.ebuild
new file mode 100644
index 000000000000..044b16b4a52d
--- /dev/null
+++ b/sci-biology/diya/diya-1.0_rc4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/diya/diya-1.0_rc4.ebuild,v 1.1 2009/09/28 00:16:02 weaver Exp $
+
+EAPI="2"
+
+inherit perl-module
+
+DESCRIPTION="Do It Yourself Annotation, a collection of tools and libraries for sequence assembly and annotation"
+HOMEPAGE="http://gmod.org/wiki/Diya"
+SRC_URI="mirror://sourceforge/diyg/files/diya/diya-1.0/diya-${PV/_/-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="-minimal"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sci-biology/bioperl
+ dev-perl/Data-Utilities
+ dev-perl/XML-Simple"
+RDEPEND="${DEPEND}
+ !minimal? (
+ sci-biology/mummer
+ sci-biology/glimmer
+ sci-biology/trnascan-se
+ sci-biology/infernal )"
+
+# see ftp://ftp.ncbi.nih.gov/blast/ to check if blast and blast+ are different from ncbi-tools and ncbi-tools++
+# * rfamscan.pl v0.1 (http://www.sanger.ac.uk/Users/sgj/code/)
+# * UniRef50 (http://www.ebi.ac.uk/uniref/)
+# * Protein Clusters (ftp://ftp.ncbi.nih.gov/genomes/Bacteria/CLUSTERS/)
+# The file cddid_all.tbl can be found at ftp://ftp.ncbi.nih.gov/pub/mmdb/cdd/.
+
+S="${WORKDIR}/diya-${PV/_/-}"
+
+SRC_TEST=do
+
+src_install() {
+ mydoc="INSTALL README docs/diya.html"
+ perl-module_src_install
+ insinto /usr/share/${PN}
+ doins -r diya.conf docs examples scripts || die
+}
diff --git a/sci-biology/diya/metadata.xml b/sci-biology/diya/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/diya/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>