summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-28 21:32:20 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-28 21:32:20 +0000
commitf17a8f91cff185da01c86d3f46d119e31a59d8ba (patch)
tree75be2829893ea9694c26d664f1d4acbafbdab817 /sci-biology/mira/mira-3.0.5.ebuild
parentMask package dev-haskell/filepath. (diff)
downloadhistorical-f17a8f91cff185da01c86d3f46d119e31a59d8ba.tar.gz
historical-f17a8f91cff185da01c86d3f46d119e31a59d8ba.tar.bz2
historical-f17a8f91cff185da01c86d3f46d119e31a59d8ba.zip
Prepared for prefix, #325929
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/mira/mira-3.0.5.ebuild')
-rw-r--r--sci-biology/mira/mira-3.0.5.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/sci-biology/mira/mira-3.0.5.ebuild b/sci-biology/mira/mira-3.0.5.ebuild
index 00d6e0a564f6..b1219203ea53 100644
--- a/sci-biology/mira/mira-3.0.5.ebuild
+++ b/sci-biology/mira/mira-3.0.5.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.5.ebuild,v 1.1 2010/05/05 08:00:05 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.5.ebuild,v 1.2 2010/06/28 21:32:20 jlec Exp $
-EAPI="2"
+EAPI="3"
MIRA_3RDPARTY_PV="17-04-2010"
-inherit base autotools
+inherit autotools base multilib
DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
HOMEPAGE="http://www.chevreux.org/projects_mira.html"
@@ -16,7 +16,7 @@ SRC_URI="mirror://sourceforge/mira-assembler/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
CDEPEND=">=dev-libs/boost-1.35.0"
DEPEND="${CDEPEND}
@@ -30,6 +30,13 @@ src_prepare() {
AT_M4DIR="config/m4" eautoreconf
}
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-thread=boost_thread-mt
+}
+
src_compile() {
base_src_compile
if use doc; then emake -C doc clean docs || die; fi