summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-23 21:37:02 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-23 21:37:02 +0000
commit292c28eab850180d81fa4b32d05d284045f2052f (patch)
treeccc0bb075c3e7d58513b9e70798fbee7b5b2bd7d /sci-biology/phylip/phylip-3.62.ebuild
parentMoving to sci-biology/phylip (diff)
downloadhistorical-292c28eab850180d81fa4b32d05d284045f2052f.tar.gz
historical-292c28eab850180d81fa4b32d05d284045f2052f.tar.bz2
historical-292c28eab850180d81fa4b32d05d284045f2052f.zip
Moved from app-sci/phylip to sci-biology/phylip.
Diffstat (limited to 'sci-biology/phylip/phylip-3.62.ebuild')
-rw-r--r--sci-biology/phylip/phylip-3.62.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/phylip/phylip-3.62.ebuild b/sci-biology/phylip/phylip-3.62.ebuild
new file mode 100644
index 000000000000..062a535900cf
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.62.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.62.ebuild,v 1.1 2004/12/23 21:37:02 ribosome Exp $
+
+inherit gcc
+
+DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
+HOMEPAGE="http://evolution.genetics.washington.edu/${PN}.html"
+SRC_URI="ftp://evolution.genetics.washington.edu/pub/${PN}/${P}.tar.gz"
+LICENSE="freedist"
+
+SLOT="0"
+KEYWORDS="x86 ~ppc ~ppc-macos"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/x11"
+
+S=${WORKDIR}/${P}/src
+
+src_compile() {
+ sed -i -e "s/CFLAGS =/CFLAGS = ${CFLAGS}/" Makefile
+ sed -i -e "s/CC = cc/CC = $(gcc-getCC)/" Makefile
+ sed -i -e "s/DC = cc/DC = $(gcc-getCC)/" Makefile
+ mkdir ../fonts
+ emake -j1 all put || die
+ mv ../exe/font* ../fonts
+}
+
+src_install()
+{
+ cd ${WORKDIR}/${P}
+
+ dobin exe/*
+
+ dohtml phylip.html
+ insinto /usr/share/doc/${PF}/html/doc
+ doins doc/*
+
+ insinto /usr/share/${PN}/fonts
+ doins fonts/*
+}