summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-07-20 00:56:03 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-07-20 00:56:03 +0000
commitf4efdc96e6b44b03b8f19b55f7e4ab60956a38d6 (patch)
tree1dc4e0ee8ef35ffcf2531a7585e2ae48f32e091d /sci-biology
parentNew package, ebuild written by me, dependency of sci-biology/GBrowse (diff)
downloadhistorical-f4efdc96e6b44b03b8f19b55f7e4ab60956a38d6.tar.gz
historical-f4efdc96e6b44b03b8f19b55f7e4ab60956a38d6.tar.bz2
historical-f4efdc96e6b44b03b8f19b55f7e4ab60956a38d6.zip
Import from sci overlay, rename and rewrite; thanks to Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> and Justin Lecher <jlec@gentoo.org>
Package-Manager: portage-2.2.0_alpha45/cvs/Linux x86_64
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/GBrowse/ChangeLog11
-rw-r--r--sci-biology/GBrowse/GBrowse-2.39.ebuild68
-rw-r--r--sci-biology/GBrowse/Manifest15
-rw-r--r--sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch72
-rw-r--r--sci-biology/GBrowse/metadata.xml13
5 files changed, 179 insertions, 0 deletions
diff --git a/sci-biology/GBrowse/ChangeLog b/sci-biology/GBrowse/ChangeLog
new file mode 100644
index 000000000000..962c42fadde1
--- /dev/null
+++ b/sci-biology/GBrowse/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-biology/GBrowse
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/GBrowse/ChangeLog,v 1.1 2011/07/20 00:56:03 weaver Exp $
+
+*GBrowse-2.39 (20 Jul 2011)
+
+ 20 Jul 2011; Andrey Kislyuk <weaver@gentoo.org> +GBrowse-2.39.ebuild,
+ +files/GBrowseInstall.pm-2.39.patch, +metadata.xml:
+ Import from sci overlay, rename and rewrite; thanks to Martin Mokrejs
+ <mmokrejs@fold.natur.cuni.cz> and Justin Lecher <jlec@gentoo.org>
+
diff --git a/sci-biology/GBrowse/GBrowse-2.39.ebuild b/sci-biology/GBrowse/GBrowse-2.39.ebuild
new file mode 100644
index 000000000000..b842940d510b
--- /dev/null
+++ b/sci-biology/GBrowse/GBrowse-2.39.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/GBrowse/GBrowse-2.39.ebuild,v 1.1 2011/07/20 00:56:03 weaver Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=LDS
+inherit perl-module webapp
+
+DESCRIPTION="Generic Model Organism Database Project - The Generic Genome Browser"
+HOMEPAGE="http://gmod.org/wiki/GBrowse"
+KEYWORDS="~amd64 ~x86"
+IUSE="-minimal mysql postgres +sqlite"
+
+CDEPEND=">=sci-biology/bioperl-1.6.9
+ >=dev-perl/Bio-Graphics-2.09
+ >=dev-perl/GD-2.07
+ >=dev-perl/CGI-Session-4.02
+ dev-perl/IO-String
+ dev-perl/JSON
+ dev-perl/libwww-perl
+ dev-perl/Statistics-Descriptive
+ !minimal? (
+ dev-perl/Bio-Das
+ >=dev-perl/Bio-SamTools-1.20
+ dev-perl/Crypt-SSLeay
+ dev-perl/DB_File-Lock
+ dev-perl/DBI
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ sqlite? ( dev-perl/DBD-SQLite )
+ dev-perl/FCGI
+ dev-perl/File-NFSLock
+ dev-perl/GD-SVG
+ dev-perl/Net-OpenID-Consumer
+ dev-perl/Net-SMTP-SSL
+ )"
+# >=dev-perl/Bio-DB-BigFile-1.00 - requires jklib to compile
+DEPEND="virtual/perl-Module-Build
+ dev-perl/Capture-Tiny
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}"/GBrowseInstall.pm-${PV}.patch )
+
+src_configure() {
+ webapp_src_preinst
+
+# myconf="--install_base=${D}/usr" or "--install_base=/opt/gbrowse"
+ myconf="--conf=/etc/gbrowse2"
+ myconf="${myconf} --htdocs=${MY_HTDOCSDIR}"
+ myconf="${myconf} --cgibin=${MY_CGIBINDIR}"
+ myconf="${myconf} --tmp=/var/tmp/gbrowse2"
+ myconf="${myconf} --persistent=/var/db/gbrowse2"
+ myconf="${myconf} --databases=/var/db/gbrowse2/databases"
+ myconf="${myconf} --installconf=no"
+ myconf="${myconf} --installetc=no"
+ perl-module_src_configure
+}
+
+src_install() {
+ dodir /var/tmp/gbrowse2
+ dodir /var/db/gbrowse2/sessions
+ dodir /var/db/gbrowse2/userdata
+ webapp_serverowned -R /var/tmp/gbrowse2 /var/db/gbrowse2
+ perl-module_src_install
+ webapp_src_install
+}
diff --git a/sci-biology/GBrowse/Manifest b/sci-biology/GBrowse/Manifest
new file mode 100644
index 000000000000..aa7cdeea3d67
--- /dev/null
+++ b/sci-biology/GBrowse/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX GBrowseInstall.pm-2.39.patch 2878 RMD160 24dc53700c23521fb0e892ed1d675142eefc2c65 SHA1 961c73f9a83c101932558cd28945cfe2e5cc4b7f SHA256 80a1aefac21c55c040e89028f736c058b35695cbb816e44f4465665cdd14f9ab
+DIST GBrowse-2.39.tar.gz 11969088 RMD160 47dd338a0b99632e77a532a3c27d0b9d9d514dca SHA1 2cc48cc1603aa3ae487c47259f9a896bec4eff8e SHA256 b4e76acfa1d8f64d5f227c3ba0258666928b4f357428549be85f05c944337d44
+EBUILD GBrowse-2.39.ebuild 1916 RMD160 83a3031201321d64d9f8f0f22956e9778a9b2b12 SHA1 a011f1d5e9b29676db6e41a5d5f6e28d70770e4b SHA256 be9a81871de7957a39407c31f9c5ef291b5d1e0a9698d2460a6b44ce2d68cc11
+MISC ChangeLog 507 RMD160 3b8bc809f1220a6384e2230374eaec6f60ad3d68 SHA1 99c8bb305dfe14a9981b397c7a0bc415692f32c1 SHA256 d414d7a8180d22107f48c760dfc9c4d7038d7e7fdaf94b52a077fa3f4653b599
+MISC metadata.xml 352 RMD160 c409abbd5e93c39f874f62376148fa32b7b93dd2 SHA1 9c92894b7db29b6e74ac51e0acbe457bd6e523a5 SHA256 b4ac9f3ef6106473d6685685245180ff6191165751d8c83d033f7ef0e918e82f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.11 (GNU/Linux)
+
+iEYEARECAAYFAk4mJ6kACgkQ8xSwyhbn2ObxJQCgmHKXPMD/s3TJ0UrDpqHiXWlP
+T0cAoKIaPtBbGv7ToES76ff/hxTwM9nV
+=NQga
+-----END PGP SIGNATURE-----
diff --git a/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch b/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch
new file mode 100644
index 000000000000..5aa0be9df918
--- /dev/null
+++ b/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch
@@ -0,0 +1,72 @@
+diff -durr GBrowse-2.39-orig/install_util/GBrowseInstall.pm GBrowse-2.39/install_util/GBrowseInstall.pm
+--- GBrowse-2.39-orig/install_util/GBrowseInstall.pm 2011-07-19 20:14:52.434608020 +0000
++++ GBrowse-2.39/install_util/GBrowseInstall.pm 2011-07-19 21:02:13.685107753 +0000
+@@ -454,33 +454,33 @@
+ $gid =~ /^(\d+)$/;
+ $gid = $1;
+
+- unless (chown $uid,$gid,$tmp) {
+- $self->ownership_warning($tmp,$user);
+- }
++# unless (chown $uid,$gid,$tmp) {
++# $self->ownership_warning($tmp,$user);
++# }
+
+ my $htdocs_i = File::Spec->catfile($self->install_path->{htdocs},'i');
+ my $images = File::Spec->catfile($tmp,'images');
+ my $htdocs = $self->install_path->{htdocs};
+- chown $uid,-1,$htdocs;
++# chown $uid,-1,$htdocs;
+ {
+ local $> = $uid;
+- symlink($images,$htdocs_i); # so symlinkifowner match works!
++# symlink($images,$htdocs_i); # so symlinkifowner match works!
+ }
+- chown $>,-1,$self->install_path->{htdocs};
++# chown $>,-1,$self->install_path->{htdocs};
+
+ my $persistent = $self->install_path->{'persistent'};
+ my $sessions = File::Spec->catfile($persistent,'sessions');
+ my $userdata = File::Spec->catfile($persistent,'userdata');
+- mkpath([$sessions,$userdata],0711);
++# mkpath([$sessions,$userdata],0711);
+
+ my $databases = $self->install_path->{'databases'};
+
+- unless (chown $uid,$gid,glob(File::Spec->catfile($databases,'').'*')) {
+- $self->ownership_warning($databases,$user);
+- }
++# unless (chown $uid,$gid,glob(File::Spec->catfile($databases,'').'*')) {
++# $self->ownership_warning($databases,$user);
++# }
+
+- chmod 0755,File::Spec->catfile($self->install_path->{'etc'},'init.d','gbrowse-slave');
+- $self->fix_selinux;
++ # chmod 0755,File::Spec->catfile($self->install_path->{'etc'},'init.d','gbrowse-slave');
++ # $self->fix_selinux;
+
+ my $base = basename($self->install_path->{htdocs});
+
+@@ -489,14 +489,14 @@
+ my $metadb_script = File::Spec->catfile("bin", "gbrowse_metadb_config.pl");
+ my $perl = $self->perl;
+ my @inc = map{"-I$_"} split ':',$self->added_to_INC;
+- system $perl,@inc,$metadb_script;
+- system 'sudo','chown','-R',"$uid.$gid",$sessions,$userdata;
++# system $perl,@inc,$metadb_script;
++# system 'sudo','chown','-R',"$uid.$gid",$sessions,$userdata;
+
+- if (Module::Build->y_n(
+- "It is recommended that you restart Apache. Shall I try this for you?",'y'
+- )) {
+- system "sudo /etc/init.d/apache2 restart";
+- }
++# if (Module::Build->y_n(
++# "It is recommended that you restart Apache. Shall I try this for you?",'y'
++# )) {
++# system "sudo /etc/init.d/apache2 restart";
++# }
+
+ print STDERR "\n***INSTALLATION COMPLETE***\n";
+ print STDERR "Load http://localhost/$base for demo and documentation.\n";
+Only in GBrowse-2.39/install_util: GBrowseInstall.pm~
diff --git a/sci-biology/GBrowse/metadata.xml b/sci-biology/GBrowse/metadata.xml
new file mode 100644
index 000000000000..ba6459e35d02
--- /dev/null
+++ b/sci-biology/GBrowse/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>perl</herd>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">GBrowse</remote-id>
+ </upstream>
+</pkgmetadata>