summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-01-04 15:01:08 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-01-04 15:01:08 +0000
commit0bcc262267b17e8f71f9ed5e0787eed57dd866e6 (patch)
treecaffd7c7982e3270327681365ea3e04513847e38 /sci-calculators/qalculate-units/qalculate-units-0.9.4-r1.ebuild
parentStable on sparc wrt #159802 (diff)
downloadhistorical-0bcc262267b17e8f71f9ed5e0787eed57dd866e6.tar.gz
historical-0bcc262267b17e8f71f9ed5e0787eed57dd866e6.tar.bz2
historical-0bcc262267b17e8f71f9ed5e0787eed57dd866e6.zip
Added revision which can be compiled against newer versions of libqalculate.
Package-Manager: portage-2.1.2_rc4-r4
Diffstat (limited to 'sci-calculators/qalculate-units/qalculate-units-0.9.4-r1.ebuild')
-rw-r--r--sci-calculators/qalculate-units/qalculate-units-0.9.4-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-calculators/qalculate-units/qalculate-units-0.9.4-r1.ebuild b/sci-calculators/qalculate-units/qalculate-units-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..0f6b6a1ab846
--- /dev/null
+++ b/sci-calculators/qalculate-units/qalculate-units-0.9.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-units/qalculate-units-0.9.4-r1.ebuild,v 1.1 2007/01/04 14:58:19 markusle Exp $
+
+DESCRIPTION="A GTK+ unit conversion tool"
+LICENSE="GPL-2"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+
+SLOT="0"
+IUSE="nls"
+KEYWORDS="~x86"
+
+DEPEND=">=sci-libs/libqalculate-0.9.4
+ >=x11-libs/gtk+-2.4
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf --disable-clntest || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Installation failed."
+ dodoc AUTHORS ChangeLog README || die "Failed to install documentation."
+}