summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-18 18:34:15 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-18 18:34:15 +0000
commit1677731b89387604411b226d0c97d9635c962aa2 (patch)
tree8e9c30c3ab1c49977260eb38a13cc7dfe7cb160d /sci-chemistry/coot/coot-0.6.1.ebuild
parentwhitespace (diff)
downloadhistorical-1677731b89387604411b226d0c97d9635c962aa2.tar.gz
historical-1677731b89387604411b226d0c97d9635c962aa2.tar.bz2
historical-1677731b89387604411b226d0c97d9635c962aa2.zip
Fix for tests, #333845
Package-Manager: portage-2.2.0_alpha17/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/coot/coot-0.6.1.ebuild')
-rw-r--r--sci-chemistry/coot/coot-0.6.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-chemistry/coot/coot-0.6.1.ebuild b/sci-chemistry/coot/coot-0.6.1.ebuild
index 72da2dfbf6a8..d1a8ffd8977d 100644
--- a/sci-chemistry/coot/coot-0.6.1.ebuild
+++ b/sci-chemistry/coot/coot-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.1.ebuild,v 1.7 2011/01/12 08:19:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.1.ebuild,v 1.8 2011/01/18 18:34:15 jlec Exp $
EAPI="3"
@@ -108,6 +108,7 @@ src_compile() {
}
src_test() {
+ source "${EPREFIX}/etc/profile.d/40ccp4.setup.sh"
mkdir "${T}"/coot_test
export COOT_STANDARD_RESIDUES="${S}/standard-residues.pdb"
@@ -120,6 +121,7 @@ src_test() {
export PYTHONHOME="${EPREFIX}"/usr
export CCP4_SCR="${T}"/coot_test
export CLIBD_MON="${EPREFIX}/usr/share/ccp4/data/monomers/"
+ export SYMINFO="${S}/syminfo.lib"
export COOT_TEST_DATA_DIR="${WORKDIR}"/data/greg-data
@@ -145,6 +147,7 @@ src_test() {
einfo "PYTHONHOME $PYTHONHOME"
einfo "CCP4_SCR ${CCP4_SCR}"
einfo "CLIBD_MON ${CLIBD_MON}"
+ einfo "SYMINFO ${SYMINFO}"
"${S}"/src/coot-real --no-graphics --script command-line-greg.scm || die
}