summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-05 17:53:22 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-05 17:53:22 +0000
commit8a4c51e55679f81d927440d8d8f4eb9eef81d28e (patch)
treee2fa9e413760944c3372b18a664fb66653ee9ce2 /sci-chemistry/mopac7
parentMarked ~amd64. (diff)
downloadhistorical-8a4c51e55679f81d927440d8d8f4eb9eef81d28e.tar.gz
historical-8a4c51e55679f81d927440d8d8f4eb9eef81d28e.tar.bz2
historical-8a4c51e55679f81d927440d8d8f4eb9eef81d28e.zip
(#101288) Fix run_mopac7 shell script, courtesy of Mathias Weigt <m.weigt@uni-bonn.de>.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/ChangeLog9
-rw-r--r--sci-chemistry/mopac7/Manifest4
-rw-r--r--sci-chemistry/mopac7/files/digest-mopac7-1.00-r11
-rw-r--r--sci-chemistry/mopac7/mopac7-1.00-r1.ebuild40
4 files changed, 52 insertions, 2 deletions
diff --git a/sci-chemistry/mopac7/ChangeLog b/sci-chemistry/mopac7/ChangeLog
index fe0d597c82dd..a3b0310e9340 100644
--- a/sci-chemistry/mopac7/ChangeLog
+++ b/sci-chemistry/mopac7/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/mopac7
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.3 2005/07/10 06:01:35 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.4 2005/08/05 17:53:22 spyderous Exp $
+
+*mopac7-1.00-r1 (05 Aug 2005)
+
+ 05 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +mopac7-1.00-r1.ebuild:
+ (#101288) Fix run_mopac7 shell script, courtesy of Mathias Weigt
+ <m.weigt@uni-bonn.de>.
10 Jul 2005; Donnie Berkholz <spyderous@gentoo.org>; mopac7-1.00.ebuild:
(#98457) Parallel build broken.
diff --git a/sci-chemistry/mopac7/Manifest b/sci-chemistry/mopac7/Manifest
index b184167a181d..b3ced5e11610 100644
--- a/sci-chemistry/mopac7/Manifest
+++ b/sci-chemistry/mopac7/Manifest
@@ -1,4 +1,6 @@
MD5 5f769fd057531c884af54fb23ba99f50 mopac7-1.00.ebuild 1332
MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
-MD5 d0f673021b0f9d49eec18269d02d1c35 ChangeLog 668
+MD5 777c12b9723329c10fbca56750445e6e ChangeLog 873
+MD5 b587431a5b74ca23d7c00b7a765cad37 mopac7-1.00-r1.ebuild 1333
MD5 87fd0c849cee4758e25fa67f07f7240e files/digest-mopac7-1.00 61
+MD5 87fd0c849cee4758e25fa67f07f7240e files/digest-mopac7-1.00-r1 61
diff --git a/sci-chemistry/mopac7/files/digest-mopac7-1.00-r1 b/sci-chemistry/mopac7/files/digest-mopac7-1.00-r1
new file mode 100644
index 000000000000..dacf853ca0d4
--- /dev/null
+++ b/sci-chemistry/mopac7/files/digest-mopac7-1.00-r1
@@ -0,0 +1 @@
+MD5 d556f7166bcc809dd84ee93c8d874fa2 mopac7-1.00.tgz 1184447
diff --git a/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild b/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild
new file mode 100644
index 000000000000..e4f62f3e9385
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.00-r1.ebuild,v 1.1 2005/08/05 17:53:22 spyderous Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-libs/libf2c
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+RDEPEND="dev-libs/libf2c"
+
+src_compile() {
+ libtoolize --copy --force
+
+ # This is absolutely required to avoid odd errors on MAIN__() not existing
+ # and to build the mopac7 binary, not just the library.
+ einfo "Adding required LDFLAGS for configure"
+ econf LDFLAGS="-Xlinker -defsym -Xlinker MAIN__=main" || die "econf failed"
+
+ # We need the appended LDFLAGS to activate building of the mopac7 binary,
+ # but they break the actual linking of it. Something's obviously broken.
+ einfo "Removing LDFLAGS, as they break the build"
+ sed -i "/^LDFLAGS/d" src/Makefile.in
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ sed -i "s:./src/mopac7:mopac7:g" run_mopac7
+ dobin run_mopac7 src/.libs/mopac7
+ dodoc AUTHORS README ChangeLog
+}