summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-25 16:24:21 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-25 16:24:21 +0000
commitc6d03d56f291893786115aaca0cdb044d0dca154 (patch)
tree122b0f467ca7871ba2854892c1ad5d2d0ce58678 /sci-chemistry
parentRestoring due to dev-dotnet/evolution-sharp-0.18.1 requiring it (diff)
downloadhistorical-c6d03d56f291893786115aaca0cdb044d0dca154.tar.gz
historical-c6d03d56f291893786115aaca0cdb044d0dca154.tar.bz2
historical-c6d03d56f291893786115aaca0cdb044d0dca154.zip
New plugin for pymol
Package-Manager: portage-2.2_rc63/cvs/Linux i686
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-plugins-emovie/ChangeLog15
-rw-r--r--sci-chemistry/pymol-plugins-emovie/Manifest15
-rw-r--r--sci-chemistry/pymol-plugins-emovie/files/1.0.4-indent.patch22
-rw-r--r--sci-chemistry/pymol-plugins-emovie/metadata.xml7
-rw-r--r--sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild54
5 files changed, 113 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-emovie/ChangeLog b/sci-chemistry/pymol-plugins-emovie/ChangeLog
new file mode 100644
index 000000000000..b2700256249c
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-emovie/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sci-chemistry/pymol-plugins-emovie
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-emovie/ChangeLog,v 1.1 2010/02/25 16:24:20 jlec Exp $
+
+*pymol-plugins-emovie-1.0.4 (25 Feb 2010)
+
+ 25 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +files/1.0.4-indent.patch, +pymol-plugins-emovie-1.0.4.ebuild,
+ +metadata.xml:
+ eMovie is a free tool that makes the creation of molecular movies both
+ easy and intuitive via a breakthrough storyboard interface, similar in
+ nature to what is used in the creation of traditional movies. eMovie is a
+ plug-in for PyMOL, a powerful, open source, and multi-platform molecular
+ graphics program.
+
diff --git a/sci-chemistry/pymol-plugins-emovie/Manifest b/sci-chemistry/pymol-plugins-emovie/Manifest
new file mode 100644
index 000000000000..e3ae23b349df
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-emovie/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 1.0.4-indent.patch 706 RMD160 f4ffb91dd86610f053f471b949d6a3631f7ad2dd SHA1 b140c8376bcb0a9fd1884817612f6c05b79a0fc6 SHA256 b57d251335f97ab49386b0acc5b41c231ee56b1ad134eb85abd71a576e9ecc6b
+DIST eMovie_package.zip 22840 RMD160 1576bbf2007f82f6d06b0a79d45ee634d1d28be5 SHA1 4a3ed376cfe612f515c9d0390d5c4b0dead8de72 SHA256 a899d08f43902f803a797ddbd1052c687db03add53b2f815c91ae83223cc7f82
+EBUILD pymol-plugins-emovie-1.0.4.ebuild 1332 RMD160 e1d0f82de87a3121d9713d69821df8d7e6af9c6a SHA1 e959c4137897ee97ab322891981af147e7692bad SHA256 1c0d285253f8129914ea82e62c575f81daaaf16aeb8b30e873c12368d7617033
+MISC ChangeLog 739 RMD160 ffb16f0e30ec451ffd15c5d608362b7b68c238b4 SHA1 9ad0e78ac95813d4b38246c08ca160981206a760 SHA256 077f8f1a6e945dbcfa6ceb92f57a6e6fcce704949c87d8b1f95a8cc4b8c08cd9
+MISC metadata.xml 155 RMD160 823aafbb307031f1ba3623843c40fe2af7f376f3 SHA1 ea03b508a56c4cd85e21caf05a62bfd5434f2f93 SHA256 de2f6a1991e072c277c19b5e3ab298de09621d33dacd7c2a99fe430d77745d8b
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkuGpD8ACgkQgAnW8HDreRafRgCffksHM/2U4WbpXCBVWkGgO3U6
+ctAAn2UL1EjEYupb3g2zPxJubTMQa64k
+=3OGe
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/pymol-plugins-emovie/files/1.0.4-indent.patch b/sci-chemistry/pymol-plugins-emovie/files/1.0.4-indent.patch
new file mode 100644
index 000000000000..a9a77e5055dd
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-emovie/files/1.0.4-indent.patch
@@ -0,0 +1,22 @@
+diff --git a/eMovie.py b/eMovie.py
+index a865732..8b5b068 100644
+--- a/eMovie.py
++++ b/eMovie.py
+@@ -931,7 +931,7 @@ class Story(tkSimpleDialog.Dialog):
+
+ if self.parent is not None:
+ self.geometry("+%d+%d" % (parent.winfo_rootx()+50,parent.winfo_rooty()+50))
+- self.initial_focus.focus_set()
++ self.initial_focus.focus_set()
+
+ self.wait_window(self)
+
+@@ -2041,7 +2041,7 @@ class AddMorph(tkSimpleDialog.Dialog):
+
+ if self.parent is not None:
+ self.geometry("+%d+%d" % (parent.winfo_rootx()+50,parent.winfo_rooty()+50))
+- self.initial_focus.focus_set()
++ self.initial_focus.focus_set()
+
+ self.wait_window(self)
+
diff --git a/sci-chemistry/pymol-plugins-emovie/metadata.xml b/sci-chemistry/pymol-plugins-emovie/metadata.xml
new file mode 100644
index 000000000000..4128e98fc529
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-emovie/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild b/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
new file mode 100644
index 000000000000..fcb179057b27
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild,v 1.1 2010/02/25 16:24:20 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python
+
+DESCRIPTION="eMovie is a plug-in tool for the molecular visualization program PyMOL"
+SRC_URI="http://www.weizmann.ac.il/ISPC/eMovie_package.zip"
+HOMEPAGE="http://www.weizmann.ac.il/ISPC/eMovie.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~x86-linux ~amd64-linux"
+IUSE=""
+
+RDEPEND=">sci-chemistry/pymol-0.99"
+DEPEND="app-arch/unzip"
+#RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-indent.patch
+
+ mkdir ${P}
+ mv e* ${P}/
+
+ python_copy_sources --no-link
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+
+ 2to3-${PYTHON_ABI} -w eMovie.py > /dev/null
+ }
+ python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
+}
+
+src_install(){
+ installation() {
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins eMovie.py || die
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst(){
+ python_mod_optimize pmg_tk/startup
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup
+}