summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-02-16 23:52:46 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-02-16 23:52:46 +0000
commit74297c1d89a62cf5c069d6a5df3636f1e4c545b9 (patch)
tree5857d54651540f2c74d3c45ca8c79ac8019e2151 /sci-electronics/tclspice/tclspice-0.2.17.ebuild
parentremove (diff)
downloadhistorical-74297c1d89a62cf5c069d6a5df3636f1e4c545b9.tar.gz
historical-74297c1d89a62cf5c069d6a5df3636f1e4c545b9.tar.bz2
historical-74297c1d89a62cf5c069d6a5df3636f1e4c545b9.zip
Fixed bug 82279, added to ~ppc.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sci-electronics/tclspice/tclspice-0.2.17.ebuild')
-rw-r--r--sci-electronics/tclspice/tclspice-0.2.17.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/sci-electronics/tclspice/tclspice-0.2.17.ebuild b/sci-electronics/tclspice/tclspice-0.2.17.ebuild
index f1d3001cc78b..12875067a16f 100644
--- a/sci-electronics/tclspice/tclspice-0.2.17.ebuild
+++ b/sci-electronics/tclspice/tclspice-0.2.17.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/tclspice/tclspice-0.2.17.ebuild,v 1.1 2004/12/27 20:25:42 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/tclspice/tclspice-0.2.17.ebuild,v 1.2 2005/02/16 23:52:46 hansmi Exp $
+
+inherit libtool gnuconfig
DESCRIPTION="Spice circuit simulator with TCL scripting language and GUI"
HOMEPAGE="http://tclspice.sf.net/"
@@ -10,7 +12,7 @@ IUSE=""
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="~x86 ~sparc ~ppc"
DEPEND="dev-lang/tk
>=dev-tcltk/blt-2.4z
>=dev-tcltk/tclreadline-2.1.0"
@@ -21,7 +23,19 @@ RDEPEND="$DEPEND
S=${WORKDIR}/${PN}
MAKEOPTS="$MAKEOPTS -j1" # Seems to get out-of-sync and break otherwise
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ elibtoolize
+
+ # Fix an error that happens at least on ppc
+ sed -i -e '/#include <assert.h>/ i#include <stdlib.h>' \
+ src/xspice/cmpp/ifs_yacc.y
+}
+
src_compile() {
+ gnuconfig_update
+
econf --enable-xspice --enable-experimental --with-tcl || die
emake tcl || die
}