summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-31 10:37:29 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-31 10:37:29 +0000
commit9fcf3f4b54fccfc22bd7ca5c5de6006d1820107b (patch)
tree895a55114dab39e0a342047ead3c807bfd9e43ef /sci-libs/cgcode
parentold (diff)
downloadhistorical-9fcf3f4b54fccfc22bd7ca5c5de6006d1820107b.tar.gz
historical-9fcf3f4b54fccfc22bd7ca5c5de6006d1820107b.tar.bz2
historical-9fcf3f4b54fccfc22bd7ca5c5de6006d1820107b.zip
New addition
Package-Manager: portage-2.2.0_alpha2/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/cgcode')
-rw-r--r--sci-libs/cgcode/ChangeLog10
-rw-r--r--sci-libs/cgcode/Manifest15
-rw-r--r--sci-libs/cgcode/cgcode-1.0.ebuild39
-rw-r--r--sci-libs/cgcode/files/1.0-gentoo.patch83
-rw-r--r--sci-libs/cgcode/metadata.xml8
5 files changed, 155 insertions, 0 deletions
diff --git a/sci-libs/cgcode/ChangeLog b/sci-libs/cgcode/ChangeLog
new file mode 100644
index 000000000000..989b065063d6
--- /dev/null
+++ b/sci-libs/cgcode/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/cgcode
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cgcode/ChangeLog,v 1.1 2010/10/31 10:37:29 jlec Exp $
+
+*cgcode-1.0 (31 Oct 2010)
+
+ 31 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/1.0-gentoo.patch,
+ +cgcode-1.0.ebuild, +metadata.xml:
+ New addition
+
diff --git a/sci-libs/cgcode/Manifest b/sci-libs/cgcode/Manifest
new file mode 100644
index 000000000000..4d0cdc9be07b
--- /dev/null
+++ b/sci-libs/cgcode/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 1.0-gentoo.patch 2316 RMD160 acebc3ddf57c30954013a8bba47eb0ef9f4e3756 SHA1 68dd867dd372dcd58768232e9e16da7f3e55700f SHA256 0d92e9b43465badf7f1f1bdf26d9dd32940fee96d73680b258dddec1125cb957
+DIST cgcode-1.0.tar.gz 77941 RMD160 08630dba83d101cbb999491a0efaf4a308613ea0 SHA1 8a93a71bc684b159fa067c0a9ec3c1ff159b2dc6 SHA256 41dd5a8d388b234c26dbc514f61883530be3d0bd56abdbbde94b8724d266f594
+EBUILD cgcode-1.0.ebuild 856 RMD160 b86a561e839fe7f434181b8459bb069e14c1c676 SHA1 308832b671dedd40b231781e2c277683d01a28f8 SHA256 3fe710141b103c31007d606356ec1c437bae22d9258974072a693aadfde96f72
+MISC ChangeLog 353 RMD160 b9b9c380b77d8fcdaab3f96163f1856248cdfcfc SHA1 65399dba7fde43584e83af0ed573f00844b490e1 SHA256 e157c0e16be188144f23b8adbcc989bd8f41f50ae4e88417d1ddeeeed4af29c4
+MISC metadata.xml 216 RMD160 04a6fc4e2160b439296b52aa97d5b7d83af75508 SHA1 9561c9e6eada6aac9b503407917900529ce703e9 SHA256 24f5c205c2655ef27138c8aa087701626f5b4c666229c9ef7fe814e63ea2e776
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkzNRu4ACgkQgAnW8HDreRZInwCgxOjzrd30dXWo0fw1KyoawS9e
+T20Anj20CJ7Nc5QcCy42iWd9apuj8Ftz
+=Pwy8
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/cgcode/cgcode-1.0.ebuild b/sci-libs/cgcode/cgcode-1.0.ebuild
new file mode 100644
index 000000000000..f2f4f112ac25
--- /dev/null
+++ b/sci-libs/cgcode/cgcode-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cgcode/cgcode-1.0.ebuild,v 1.1 2010/10/31 10:37:29 jlec Exp $
+
+EAPI="3"
+
+inherit eutils fortran
+
+FORTRNC="ifort gfortran"
+
+DESCRIPTION="Conjugate gradient Codes for large sparse linear systems"
+HOMEPAGE="http://fetk.org/codes/cgcode/index.html"
+SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="virtual/blas"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+
+ cat >> make.inc <<- EOF
+ F77 = ${FORTRANC}
+ FFLAGS = ${FFLAGS}
+ BLASLIBS = $(pkg-config --libs blas)
+ EOF
+}
+
+src_install() {
+ dobin goos good || die
+ dolib.so lib${PN}.so* || die
+ dodoc INTRODUCTION NOTE README || die
+}
diff --git a/sci-libs/cgcode/files/1.0-gentoo.patch b/sci-libs/cgcode/files/1.0-gentoo.patch
new file mode 100644
index 000000000000..3313a5149181
--- /dev/null
+++ b/sci-libs/cgcode/files/1.0-gentoo.patch
@@ -0,0 +1,83 @@
+diff --git a/makefile b/makefile
+index 4813b55..f20af02 100644
+--- a/makefile
++++ b/makefile
+@@ -1,21 +1,23 @@
+
+ include make.inc
+
+-THELIBS = libcgcode.a libblas_mini.a
++THELIBS = -lcgcode
+
+ default : goos good
+
+-libs :
+- cd src ; make ; cd ../util ; make
++libs : src/libcgcode.so
++
++src/libcgcode.so:
++ $(MAKE) -C src
+
+ goos : mains.o libs
+- $(F77) $(DEBUG) $(OFLAGS) $(LFLAGS) mains.o $(THELIBS) -o goos
++ $(F77) $(LDFLAGS) mains.o -L. $(THELIBS) $(BLASLIBS) -o goos
+
+ good : maind.o libs
+- $(F77) $(DEBUG) $(OFLAGS) $(LFLAGS) maind.o $(THELIBS) -o good
++ $(F77) $(LDFLAGS) maind.o -L. $(THELIBS) $(BLASLIBS) -o good
+
+-.f.o :
+- $(F77) $(CFLAGS) $(DEBUG) $(OFLAGS) $*$ .f
++%.o : %.f
++ $(F77) $(FFLAGS) -c $<
+
+ clean :
+ rm -f *.o goos good
+diff --git a/src/makefile b/src/makefile
+index 10cf6c3..1dfd02d 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -1,16 +1,17 @@
+
+ include ../make.inc
+
+-THISLIB = libcgcode.a
++THISLIB = libcgcode.so
+ SOBJLIB = scgdrv.o scg.o scr.o scrind.o spcg.o scgnr.o scgne.o spcgnr.o spcgne.o sppcg.o spcgca.o sdpchb.o scbfix.o sckchb.o scgchk.o sonest.o msstop.o r1mach.o sratqr.o
+ DOBJLIB = dcgdrv.o dcg.o dcr.o dcrind.o dpcg.o dcgnr.o dcgne.o dpcgnr.o dpcgne.o dppcg.o dpcgca.o ddpchb.o dcbfix.o dckchb.o dcgchk.o donest.o mdstop.o d1mach.o dratqr.o depsln.o
+
+ $(THISLIB) : $(SOBJLIB) $(DOBJLIB)
+- $(AR) $(THISLIB) $(SOBJLIB) $(DOBJLIB)
+- cp $(THISLIB) ../.
++ $(F77) $(FFLAGS) $(LDFLAGS) -shared -fPIC -Wl,--soname,$(THISLIB).1 -o $(THISLIB).1.0 $(SOBJLIB) $(DOBJLIB)
++ ln -sf $(THISLIB).1.0 $(THISLIB)
++ cp $(THISLIB)* ../.
+
+-.f.o :
+- $(F77) $(CFLAGS) $(DEBUG) $(OFLAGS) $*$ .f
++%.o : %.f
++ $(F77) $(FFLAGS) -fPIC -c $<
+
+ clean :
+ rm -f *.o $(THISLIB)
+diff --git a/util/makefile b/util/makefile
+index 6dad0d1..5c9d24f 100644
+--- a/util/makefile
++++ b/util/makefile
+@@ -6,11 +6,12 @@ SOBJLIB = saxpy.o scopy.o sdot.o snrm2.o sscal.o
+ DOBJLIB = daxpy.o dcopy.o ddot.o dnrm2.o dscal.o
+
+ $(THISLIB) : $(SOBJLIB) $(DOBJLIB)
+- $(AR) $(THISLIB) $(SOBJLIB) $(DOBJLIB)
+- cp $(THISLIB) ../.
++ $(F77) $(FFLAGS) $(LDFLAGS) -shared -Wl,--soname,$(THISLIB).1 -o $(THISLIB).1.0 $(SOBJLIB) $(DOBJLIB)
++ ln -sf $(THISLIB).1.0 $(THISLIB)
++ cp $(THISLIB)* ../.
+
+-.f.o :
+- $(F77) $(CFLAGS) $(DEBUG) $(OFLAGS) $*$ .f
++%.o : %.f
++ $(F77) $(FFLAGS) -c $<
+
+ clean :
+ rm -f *.o $(THISLIB)
diff --git a/sci-libs/cgcode/metadata.xml b/sci-libs/cgcode/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-libs/cgcode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>