summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-12-03 21:12:46 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-12-03 21:12:46 +0000
commit28376f205722e5bffb02572fe83bc215f66b65cb (patch)
tree0f9137dac1698d2801e28353d4eab4e498490f10 /sci-libs/gdal
parentversion bump (diff)
downloadhistorical-28376f205722e5bffb02572fe83bc215f66b65cb.tar.gz
historical-28376f205722e5bffb02572fe83bc215f66b65cb.tar.bz2
historical-28376f205722e5bffb02572fe83bc215f66b65cb.zip
Fixes for bugs 111688 and 113480.
Package-Manager: portage-2.0.53
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog7
-rw-r--r--sci-libs/gdal/Manifest11
-rw-r--r--sci-libs/gdal/files/gdal-gcc4.patch19
-rw-r--r--sci-libs/gdal/gdal-1.2.6-r4.ebuild11
-rw-r--r--sci-libs/gdal/gdal-1.3.0-r1.ebuild9
-rw-r--r--sci-libs/gdal/gdal-1.3.1.ebuild11
6 files changed, 51 insertions, 17 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 018b5402d3f0..d7f66ffe83fa 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.19 2005/11/21 19:36:21 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.20 2005/12/03 21:12:46 nerdboy Exp $
+
+ 03 Dec 2005; Steve Arnold <nerdboy@gentoo.org> +files/gdal-gcc4.patch,
+ gdal-1.2.6-r4.ebuild, gdal-1.3.0-r1.ebuild, gdal-1.3.1.ebuild:
+ Fixes for bugs 111688 and 113480; thanks to Robert Marmorstein
+ <rmmarm@wm.edu> for the patch.
21 Nov 2005; Simon Stelling <blubb@gentoo.org> gdal-1.2.6-r4.ebuild:
stable on amd64; bug 98593
diff --git a/sci-libs/gdal/Manifest b/sci-libs/gdal/Manifest
index f7567207da0b..950e95cb8a64 100644
--- a/sci-libs/gdal/Manifest
+++ b/sci-libs/gdal/Manifest
@@ -1,11 +1,12 @@
-MD5 4c85f87e0b0fc0e9c1b180a10f20965e ChangeLog 3874
-MD5 dc56f5d75556cdbcd7c4024288ef8fcb metadata.xml 481
-MD5 04c24f1f23ec59a383dc3543853f0309 gdal-1.2.6-r4.ebuild 4027
-MD5 48feb2bdb87ccd992ef37445d0985d67 gdal-1.3.0-r1.ebuild 4083
-MD5 26bef54a0646a3b46f6af72ea52d5de8 gdal-1.3.1.ebuild 4295
+MD5 6bd6a087754ad2d609dea5eebc4feb46 ChangeLog 4113
MD5 4d15ffbcc89c38a4e5a7bbbe698207a1 files/digest-gdal-1.2.6-r4 63
MD5 d4bd0e3f81da140c24f49c6e6513b9f6 files/digest-gdal-1.3.0-r1 63
MD5 388a23e8269dd2033b621fbd5e33ca94 files/digest-gdal-1.3.1 63
MD5 8069b0c62dde416a0c74d1bf73543c9d files/gdal-1.2.6-installpathfix.patch 7786
MD5 3f4304111ffcc48b1784cc03ef64844b files/gdal-1.3.0-installpathfix.patch 7764
MD5 f93770205b88c698e73487038b46a707 files/gdal-1.3.1-installpathfix.patch 6805
+MD5 2f3f328abbefa4056b6ee71dfbfce529 files/gdal-gcc4.patch 472
+MD5 4385b3fa1edd5eb5caa39e77caa607e1 gdal-1.2.6-r4.ebuild 4165
+MD5 00a42f222dd548e86574aacdcb2c715f gdal-1.3.0-r1.ebuild 4218
+MD5 fb023982b2c96929e61be245a87f4fcc gdal-1.3.1.ebuild 4441
+MD5 dc56f5d75556cdbcd7c4024288ef8fcb metadata.xml 481
diff --git a/sci-libs/gdal/files/gdal-gcc4.patch b/sci-libs/gdal/files/gdal-gcc4.patch
new file mode 100644
index 000000000000..d6718d7f310a
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-gcc4.patch
@@ -0,0 +1,19 @@
+*** gdal-1.3.1/frmts/fit/fitdataset.cpp.old Thu Nov 24 12:14:08 2005
+--- gdal-1.3.1/frmts/fit/fitdataset.cpp Thu Nov 24 12:14:19 2005
+***************
+*** 174,180 ****
+
+ public:
+
+! FITRasterBand::FITRasterBand( FITDataset *, int );
+ ~FITRasterBand();
+
+ // should override RasterIO eventually.
+--- 174,180 ----
+
+ public:
+
+! FITRasterBand( FITDataset *, int );
+ ~FITRasterBand();
+
+ // should override RasterIO eventually.
diff --git a/sci-libs/gdal/gdal-1.2.6-r4.ebuild b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
index 1b64686d82d3..264a85bbf4d1 100644
--- a/sci-libs/gdal/gdal-1.2.6-r4.ebuild
+++ b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.6 2005/11/21 19:36:21 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.7 2005/12/03 21:12:46 nerdboy Exp $
-inherit eutils libtool gnuconfig distutils
+inherit eutils libtool gnuconfig distutils toolchain-funcs
IUSE="jpeg png geos gif jasper netcdf hdf python postgres mysql sqlite \
odbc ogdi fits gml doc debug"
@@ -13,7 +13,7 @@ SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="amd64 ~ppc sparc x86"
+KEYWORDS="~amd64 ~ppc sparc x86"
# need to get these arches updated on several libs first
#KEYWORDS="~alpha ~hppa ~ppc64"
@@ -38,13 +38,16 @@ DEPEND=">=sys-libs/zlib-1.1.4
jasper? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( >=dev-db/sqlite-3* )
doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
+ if [ $(gcc-major-version) -eq 4 ] ; then
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then
diff --git a/sci-libs/gdal/gdal-1.3.0-r1.ebuild b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
index 0911fcf79493..c53e36756854 100644
--- a/sci-libs/gdal/gdal-1.3.0-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.5 2005/11/02 08:48:21 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.6 2005/12/03 21:12:46 nerdboy Exp $
-inherit eutils libtool gnuconfig distutils
+inherit eutils libtool gnuconfig distutils toolchain-funcs
IUSE="jpeg png geos gif jasper netcdf hdf hdf5 python postgres mysql \
odbc sqlite ogdi fits gml doc debug"
@@ -39,13 +39,16 @@ DEPEND=">=sys-libs/zlib-1.1.4
jasper? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( >=dev-db/sqlite-3* )
doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
+ if [ $(gcc-major-version) -eq 4 ] ; then
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then
diff --git a/sci-libs/gdal/gdal-1.3.1.ebuild b/sci-libs/gdal/gdal-1.3.1.ebuild
index 92c76b396c48..2112b911656f 100644
--- a/sci-libs/gdal/gdal-1.3.1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.3 2005/11/02 08:48:21 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.4 2005/12/03 21:12:46 nerdboy Exp $
-inherit eutils libtool gnuconfig distutils
+inherit eutils libtool gnuconfig distutils toolchain-funcs
IUSE="jpeg png geos gif jasper netcdf hdf hdf5 python postgres \
odbc sqlite ogdi fits gml doc debug"
@@ -36,13 +36,16 @@ DEPEND=">=sys-libs/zlib-1.1.4
jasper? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( >=dev-db/sqlite-3* )
doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
+ epatch ${FILESDIR}/${P}-installpathfix.patch || die "installpath patch failed"
+ if [ $(gcc-major-version) -eq 4 ] ; then
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then