summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-02-25 06:03:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-02-25 06:03:43 +0000
commit26fccf33489b8773b74cee355f9e36565190bce9 (patch)
tree527eb43ed8b1a47bc9e43677401cfba002e1f49c /sci-libs/jama
parentFix capitalization (diff)
downloadhistorical-26fccf33489b8773b74cee355f9e36565190bce9.tar.gz
historical-26fccf33489b8773b74cee355f9e36565190bce9.tar.bz2
historical-26fccf33489b8773b74cee355f9e36565190bce9.zip
Import to the main tree
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/jama')
-rw-r--r--sci-libs/jama/ChangeLog18
-rw-r--r--sci-libs/jama/jama-1.2.5.ebuild30
-rw-r--r--sci-libs/jama/metadata.xml15
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/jama/ChangeLog b/sci-libs/jama/ChangeLog
new file mode 100644
index 000000000000..8914a93a15d9
--- /dev/null
+++ b/sci-libs/jama/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for sci-libs/jama
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/jama/ChangeLog,v 1.1 2010/02/25 06:03:43 bicatali Exp $
+
+*jama-1.2.5 (25 Feb 2010)
+
+ 25 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org> +jama-1.2.5.ebuild,
+ +metadata.xml:
+ Import to the main tree
+
+ 02 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ jama-1.2.5.ebuild:
+ Fixed for versionator and cleaning
+
+ 17 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +jama-1.2.5.ebuild:
+ Initial import
+
diff --git a/sci-libs/jama/jama-1.2.5.ebuild b/sci-libs/jama/jama-1.2.5.ebuild
new file mode 100644
index 000000000000..97d6641c3e40
--- /dev/null
+++ b/sci-libs/jama/jama-1.2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/jama/jama-1.2.5.ebuild,v 1.1 2010/02/25 06:03:43 bicatali Exp $
+
+inherit versionator
+
+MYP="${PN}$(replace_all_version_separators '')"
+DOCPV=102
+
+DESCRIPTION="Java-like matrix C++ templates"
+HOMEPAGE="http://math.nist.gov/tnt/"
+SRC_URI="http://math.nist.gov/tnt/${MYP}.zip
+ doc? ( http://math.nist.gov/tnt/${PN}${DOCPV}doc.zip )"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sci-libs/tnt"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/include
+ doins *.h || die
+ use doc && dohtml doxygen/html/*
+}
diff --git a/sci-libs/jama/metadata.xml b/sci-libs/jama/metadata.xml
new file mode 100644
index 000000000000..103f08e646a1
--- /dev/null
+++ b/sci-libs/jama/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ JAMA/C++: a translation of the Java Matrix Library, developed by the
+ Mathworks and NIST, into C++ . It includes the following routines:
+ * classical matrix linear algebra
+ * QR
+ * SVD
+ * Cholesky
+ * Eigenvalue solver
+ It is based on NIST's Template Numerical Toolkit.
+</longdescription>
+</pkgmetadata>