summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2006-11-28 18:41:50 +0000
committerChristian Faulhammer <fauli@gentoo.org>2006-11-28 18:41:50 +0000
commit5990b64588d8c72fa5bc3b7f1d4b8de8a91b3fb0 (patch)
treef9c7ff53c10bd6da6370cb55f0e042fdb3de0079 /sci-libs/plplot/plplot-5.5.2.ebuild
parentFix wrapper (diff)
downloadhistorical-5990b64588d8c72fa5bc3b7f1d4b8de8a91b3fb0.tar.gz
historical-5990b64588d8c72fa5bc3b7f1d4b8de8a91b3fb0.tar.bz2
historical-5990b64588d8c72fa5bc3b7f1d4b8de8a91b3fb0.zip
moved tcltk USE flag over to separate tk and tcl flags, see bug #17808
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'sci-libs/plplot/plplot-5.5.2.ebuild')
-rw-r--r--sci-libs/plplot/plplot-5.5.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sci-libs/plplot/plplot-5.5.2.ebuild b/sci-libs/plplot/plplot-5.5.2.ebuild
index 100768965364..839b798f4495 100644
--- a/sci-libs/plplot/plplot-5.5.2.ebuild
+++ b/sci-libs/plplot/plplot-5.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/plplot-5.5.2.ebuild,v 1.6 2006/11/18 04:54:33 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/plplot/plplot-5.5.2.ebuild,v 1.7 2006/11/28 18:41:50 opfer Exp $
inherit eutils
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc"
-IUSE="X debug doc fortran ifc itcl java jpeg octave png python tcltk tetex truetype"
+IUSE="X debug doc fortran ifc itcl java jpeg octave png python tk tetex truetype"
RDEPEND="virtual/libc
dev-lang/perl
@@ -31,8 +31,7 @@ RDEPEND="virtual/libc
x11-libs/libXdmcp
)
virtual/x11 )
- tcltk? ( dev-lang/tcl
- dev-lang/tk
+ tk? ( dev-lang/tk
itcl? ( dev-tcltk/itcl )
)
)"
@@ -127,7 +126,7 @@ src_compile() {
# Additional X-dependent language bindings and device drivers.
if use X; then
EXTRA_CONF="${EXTRA_CONF} --with-x"
- if use tcltk; then
+ if use tk; then
EXTRA_CONF="${EXTRA_CONF} --enable-tcl"
EXTRA_CONF="${EXTRA_CONF} $(use_enable itcl)"
else