summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-02-10 16:59:02 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-02-10 16:59:02 +0000
commit41e3c894c47b373e4c8a3989a4f20abaaf4f9a1e (patch)
tree96fc1c62a3c2f22fc2b692536ad7203598e7cf96 /sci-mathematics/genius
parentUpdate poppler dependency for #304319. (diff)
downloadhistorical-41e3c894c47b373e4c8a3989a4f20abaaf4f9a1e.tar.gz
historical-41e3c894c47b373e4c8a3989a4f20abaaf4f9a1e.tar.bz2
historical-41e3c894c47b373e4c8a3989a4f20abaaf4f9a1e.zip
Initial import, thanks to Joe Sapp <nixphoeni@gentoo.org>, closing bug #61143
Package-Manager: portage-2.2_rc62/cvs/Linux i686
Diffstat (limited to 'sci-mathematics/genius')
-rw-r--r--sci-mathematics/genius/ChangeLog11
-rw-r--r--sci-mathematics/genius/Manifest5
-rw-r--r--sci-mathematics/genius/genius-1.0.9.ebuild50
-rw-r--r--sci-mathematics/genius/metadata.xml19
4 files changed, 85 insertions, 0 deletions
diff --git a/sci-mathematics/genius/ChangeLog b/sci-mathematics/genius/ChangeLog
new file mode 100644
index 000000000000..48ac07a3bc24
--- /dev/null
+++ b/sci-mathematics/genius/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/genius
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.1 2010/02/10 16:59:02 grozin Exp $
+
+*genius-1.0.9 (10 Feb 2010)
+
+ 10 Feb 2010; Andrey Grozin <grozin@gentoo.org> +genius-1.0.9.ebuild,
+ +metadata.xml:
+ Initial import, thanks to Joe Sapp <nixphoeni@gentoo.org>, closing bug
+ #61143
+
diff --git a/sci-mathematics/genius/Manifest b/sci-mathematics/genius/Manifest
new file mode 100644
index 000000000000..2aa915dce4f6
--- /dev/null
+++ b/sci-mathematics/genius/Manifest
@@ -0,0 +1,5 @@
+DIST genius-1.0.9.tar.bz2 1624879 RMD160 e520dcfd1cd8ed856263a66d33dc6a487c490138 SHA1 36710898dcc5b640befe72e81b01a57bdc69c67a SHA256 5f3a7e9e8ab77e973cf83d64efcc173e5c5fa99fa96fe324e2ea82f4d3a26d68
+DIST genius-reference.pdf 1024944 RMD160 7b97fc249b5d1bf2909261b0f5a3df37e1efe459 SHA1 6c025bc2f3f292e0304ae7a45ad87f0a6b0e07b5 SHA256 79011ae33ff781507185898ba76b156699061eda78ed16e15aa02195c896ee4b
+EBUILD genius-1.0.9.ebuild 1279 RMD160 f4e60e2ddbe99ac783a8c00c338b0ec86c71c8b3 SHA1 468b434fe4807f6b1489b79f80e99cd18eeb419f SHA256 577ec18d908fdd7fb3cff756cbcea7ebd432e8c0d96e12996f17fbf840757642
+MISC ChangeLog 417 RMD160 40308192b829760d667a4c01a5d6daa9e5d146f5 SHA1 8bcb29430546210a4212527e72f3baf2ea2fb126 SHA256 28783cc7f0efdc96f94663f8fcbeb00b1cb1ca3173f999e387c8b44494622496
+MISC metadata.xml 811 RMD160 52ccdfdd2702266acc76f944d4db1cc296ac03d0 SHA1 c777cf3d0b5718d86b213df7412c297dfe9c1d3a SHA256 076635cb80b1d2a5e5ee631b207911cae60e3a87efaf856e7690d8941d0351ab
diff --git a/sci-mathematics/genius/genius-1.0.9.ebuild b/sci-mathematics/genius/genius-1.0.9.ebuild
new file mode 100644
index 000000000000..12533aff70e6
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.9.ebuild,v 1.1 2010/02/10 16:59:02 grozin Exp $
+
+EAPI=2
+inherit gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="http://www.jirka.org/${PN}.html"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc gnome nls"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/${PN}/1.0/${P}.tar.bz2
+ doc? ( http://www.jirka.org/${PN}-reference.pdf )"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/mpfr
+ dev-libs/popt
+ sys-libs/ncurses
+ sys-libs/readline
+ gnome? ( x11-libs/gtk+:2
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libglade
+ x11-libs/gtksourceview
+ x11-libs/vte )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ || ( sys-devel/bison
+ dev-util/yacc )
+ sys-devel/flex
+ app-text/scrollkeeper
+ nls? ( sys-devel/gettext )"
+
+G2CONF="${G2CONF} $(use_enable gnome) $(use_enable nls) \
+ --disable-update-mimedb --disable-scrollkeeper \
+ --disable-extra-gcc-optimization"
+GCONF_DEBUG="no"
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+USE_DESTDIR="1"
+
+src_install() {
+ gnome2_src_install
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-reference.pdf
+ fi
+}
diff --git a/sci-mathematics/genius/metadata.xml b/sci-mathematics/genius/metadata.xml
new file mode 100644
index 000000000000..cbdd7f0a35a2
--- /dev/null
+++ b/sci-mathematics/genius/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Genius is a calculator program which can work
+ with arbitrary precision integers, multiple precision floats,
+ rational numbers, complex numbers, linear algebra, number theory,
+ numerical calculus, statistics, numerical equation solving,
+ combinatorics, elementary functions, modular arithmetic.
+ It has a programming language with automatic typing.
+ It can do various 2D and 3D plots, with possibility
+ to export to eps or png. Genius has a GUI IDE.
+ It can output matrices in LaTeX, Troff (eqn) or MathML.
+ </longdescription>
+</pkgmetadata>