summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-13 02:22:15 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-13 02:22:15 +0000
commitf36cc11eed21e111c7be2e00150c92422cd23675 (patch)
tree26242ca38c3ece71a2c56915dc625489fb1c19f0 /sci-mathematics/nusmv/nusmv-2.5.0.ebuild
parentStable for HPPA (bug #325825). (diff)
downloadhistorical-f36cc11eed21e111c7be2e00150c92422cd23675.tar.gz
historical-f36cc11eed21e111c7be2e00150c92422cd23675.tar.bz2
historical-f36cc11eed21e111c7be2e00150c92422cd23675.zip
Remove forced -mcpu=pentium4 from cudd's Makefile. This fixes bug #327425 reported by Christopher Head <chris2k01@hotmail.com>. Also, added code to use correct Makefile for 64-bit systems.
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'sci-mathematics/nusmv/nusmv-2.5.0.ebuild')
-rw-r--r--sci-mathematics/nusmv/nusmv-2.5.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-mathematics/nusmv/nusmv-2.5.0.ebuild b/sci-mathematics/nusmv/nusmv-2.5.0.ebuild
index 15461364a9de..dd461fc55f7d 100644
--- a/sci-mathematics/nusmv/nusmv-2.5.0.ebuild
+++ b/sci-mathematics/nusmv/nusmv-2.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/nusmv-2.5.0.ebuild,v 1.1 2010/06/22 20:03:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/nusmv-2.5.0.ebuild,v 1.2 2010/07/13 02:22:15 phajdan.jr Exp $
inherit eutils toolchain-funcs
@@ -57,6 +57,13 @@ src_unpack() {
epatch "${FILESDIR}"/${MINISAT_P}-optimizedlib.patch
epatch "${FILESDIR}"/${MINISAT_P}_gcc41.patch
fi
+
+ cd "${CUDD_S}"
+ epatch "${FILESDIR}"/${CUDD_PN}-no-pentium4.patch
+ if [[ "$(tc-arch)" = amd64 ]] ; then
+ mv Makefile_64bit Makefile || die
+ fi
+
for i in ${NUSMV_S}/doc/{user-man,tutorial}/Makefile.in ; do
sed -i.orig \
'/install_sh_DATA/s!$(datadir)!$(DESTDIR)$(datadir)!g' \