summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-04 09:32:15 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-04 09:32:15 +0000
commit6046dcdbeed97d64b63b40500ba345ff344f7074 (patch)
tree86b2cee347500c6d523c8f98f646d59beccced34 /sci-mathematics/unuran/unuran-1.8.1.ebuild
parentUpdate Manifest with new hashes. (diff)
downloadhistorical-6046dcdbeed97d64b63b40500ba345ff344f7074.tar.gz
historical-6046dcdbeed97d64b63b40500ba345ff344f7074.tar.bz2
historical-6046dcdbeed97d64b63b40500ba345ff344f7074.zip
sci-mathematics/unuran: Move to autotool-utils.eclass
Package-Manager: portage-2.2.0_alpha115/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics/unuran/unuran-1.8.1.ebuild')
-rw-r--r--sci-mathematics/unuran/unuran-1.8.1.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/sci-mathematics/unuran/unuran-1.8.1.ebuild b/sci-mathematics/unuran/unuran-1.8.1.ebuild
index c9b95488044d..4d15d0ae8cd4 100644
--- a/sci-mathematics/unuran/unuran-1.8.1.ebuild
+++ b/sci-mathematics/unuran/unuran-1.8.1.ebuild
@@ -1,19 +1,22 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/unuran/unuran-1.8.1.ebuild,v 1.2 2012/06/26 21:19:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/unuran/unuran-1.8.1.ebuild,v 1.3 2012/07/04 09:32:15 jlec Exp $
EAPI=4
-inherit eutils
+
+inherit autotools-utils
DESCRIPTION="Universal Non-Uniform Random number generator"
HOMEPAGE="http://statmath.wu.ac.at/unuran/"
SRC_URI="${HOMEPAGE}${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT=0
KEYWORDS="~amd64 ~x86 ~amd64 ~x86-linux"
IUSE="doc examples gsl prng +rngstreams static-libs"
-DEPEND="gsl? ( sci-libs/gsl )
+
+DEPEND="
+ gsl? ( sci-libs/gsl )
prng? ( sci-mathematics/prng )
rngstreams? ( sci-mathematics/rngstreams )"
RDEPEND="${DEPEND}"
@@ -21,17 +24,18 @@ RDEPEND="${DEPEND}"
src_configure() {
local udefault=builtin
use rngstreams && udefault=rngstream
- econf \
- --enable-shared \
- --with-urng-default=${udefault} \
- $(use_enable static-libs static) \
- $(use_with gsl urng-gsl) \
- $(use_with prng urng-prng) \
+ local myeconfargs=(
+ --enable-shared
+ --with-urng-default=${udefault}
+ $(use_with gsl urng-gsl)
+ $(use_with prng urng-prng)
$(use_with rngstreams urng-rngstream)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
use doc && dodoc doc/${PN}.pdf
if use examples; then
emake distclean -C examples