summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-03 14:49:46 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-03 14:49:46 +0000
commitfb09c38a04c893eb01224198db949a421be8ae82 (patch)
tree26ed5bb4c61789e8a0ed0821565b9b50bb0226ce /sci-visualization/epix/epix-1.0.7.ebuild
parentStable on hppa. See bug #135076. (diff)
downloadhistorical-fb09c38a04c893eb01224198db949a421be8ae82.tar.gz
historical-fb09c38a04c893eb01224198db949a421be8ae82.tar.bz2
historical-fb09c38a04c893eb01224198db949a421be8ae82.zip
Bump to the most recent version which compiles fine with gcc-4.1 (see bug #135266).
Package-Manager: portage-2.1_rc3-r4
Diffstat (limited to 'sci-visualization/epix/epix-1.0.7.ebuild')
-rw-r--r--sci-visualization/epix/epix-1.0.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-visualization/epix/epix-1.0.7.ebuild b/sci-visualization/epix/epix-1.0.7.ebuild
new file mode 100644
index 000000000000..ccfdd435aee4
--- /dev/null
+++ b/sci-visualization/epix/epix-1.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.0.7.ebuild,v 1.1 2006/06/03 14:49:46 markusle Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
+HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
+SRC_URI="http://mathcs.holycross.edu/~ahwang/epix/${P}_complete.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/tetex"
+
+RDEPEND="app-shells/bash
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-doc-gentoo.patch
+ sed -e "s:/doc/${PN}:/doc/${P}:" -i Makefile.in doc/Makefile.in \
+ samples/Makefile.in
+}
+
+src_compile() {
+ econf || die "failed to configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}