summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-03-23 18:41:17 +0000
committerThomas Sachau <tommy@gentoo.org>2009-03-23 18:41:17 +0000
commit1cd7adac194c130a7a2719a62a6eda12b024ff25 (patch)
tree5a1c90dab20465be5fa8e7479f54eff28f94bf84 /skel.ebuild
parentAdded net-im/pyicq-t-0.8.1.3 (bug #262383) (diff)
downloadhistorical-1cd7adac194c130a7a2719a62a6eda12b024ff25.tar.gz
historical-1cd7adac194c130a7a2719a62a6eda12b024ff25.tar.bz2
historical-1cd7adac194c130a7a2719a62a6eda12b024ff25.zip
Update skel.ebuild as announced at gentoo-dev ML
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/skel.ebuild b/skel.ebuild
index f7a3536134b3..cee5576cfa16 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -21,14 +21,14 @@
# inherit lists eclasses to inherit functions from. Almost all ebuilds should
# inherit eutils, as a large amount of important functionality has been
-# moved there. For example, the $(get_libdir) mentioned below wont work
+# moved there. For example, the epatch call mentioned below wont work
# without the following line:
inherit eutils
# A well-used example of an eclass function that needs eutils is epatch. If
# your source needs patches applied, it's suggested to put your patch in the
# 'files' directory and use:
#
-# epatch ${FILESDIR}/patch-name-here
+# epatch "${FILESDIR}"/patch-name-here
#
# eclasses tend to list descriptions of how to use their functions properly.
# take a look at /usr/portage/eclasses/ for more examples.
@@ -96,7 +96,7 @@ IUSE="gnome X"
# had installed on your system when you tested the package. Then
# other users hopefully won't be caught without the right version of
# a dependency.
-DEPEND=""
+#DEPEND=""
# Run-time dependencies. Must be defined to whatever this depends on to run.
# The below is valid if the same run-time depends are required to compile.
@@ -108,10 +108,13 @@ RDEPEND="${DEPEND}"
# to keep it tidy.
#S="${WORKDIR}/${P}"
-src_compile() {
+
+# The following src_compile function is implemented as default by portage, so
+# you only need to call it, if you need a different behaviour.
+#src_compile() {
# Most open-source packages use GNU autoconf for configuration.
- # The quickest (and preferred) way of running configure is:
- econf || die "econf failed"
+ # The default, quickest (and preferred) way of running configure is:
+ #econf
#
# You could use something similar to the following lines to
# configure your package before compilation. The "|| die" portion
@@ -135,8 +138,9 @@ src_compile() {
# related to parallelism, in these cases, use emake -j1 to limit
# make to a single process. The -j1 is a visual clue to others
# that the makefiles have bugs that have been worked around.
- emake || die "emake failed"
-}
+
+ #emake || die "emake failed"
+#}
src_install() {
# You must *personally verify* that this trick doesn't install