summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-13 23:38:41 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-13 23:38:41 +0000
commit3a24bba0d0e46b1bc33d3f1bd865908ad9e5a24a (patch)
tree0594289ab7f1f14693e04c20cc381ea20c0d6812 /sys-apps/attr
parentFix compilation with new dev-libs/boost versions (diff)
downloadhistorical-3a24bba0d0e46b1bc33d3f1bd865908ad9e5a24a.tar.gz
historical-3a24bba0d0e46b1bc33d3f1bd865908ad9e5a24a.tar.bz2
historical-3a24bba0d0e46b1bc33d3f1bd865908ad9e5a24a.zip
Respect LDFLAGS while linking the library.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/ChangeLog6
-rw-r--r--sys-apps/attr/attr-2.4.38.ebuild3
-rw-r--r--sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch14
3 files changed, 21 insertions, 2 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index bdd42702e1e7..d6a850acd82c 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/attr
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.81 2007/05/31 06:03:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.82 2007/06/13 23:34:07 vapier Exp $
+
+ 13 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/attr-2.4.38-LDFLAGS.patch, attr-2.4.38.ebuild:
+ Respect LDFLAGS while linking the library.
*attr-2.4.38 (31 May 2007)
diff --git a/sys-apps/attr/attr-2.4.38.ebuild b/sys-apps/attr/attr-2.4.38.ebuild
index 1dedc21f3f17..b44e24b8973f 100644
--- a/sys-apps/attr/attr-2.4.38.ebuild
+++ b/sys-apps/attr/attr-2.4.38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.38.ebuild,v 1.1 2007/05/31 06:03:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.38.ebuild,v 1.2 2007/06/13 23:34:07 vapier Exp $
inherit eutils autotools toolchain-funcs
@@ -23,6 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
+ epatch "${FILESDIR}"/${PN}-2.4.38-LDFLAGS.patch
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
-e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
diff --git a/sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch b/sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch
new file mode 100644
index 000000000000..f5f1ebb74f12
--- /dev/null
+++ b/sys-apps/attr/files/attr-2.4.38-LDFLAGS.patch
@@ -0,0 +1,14 @@
+make sure the library link respects LDFLAGS
+
+http://oss.sgi.com/bugzilla/show_bug.cgi?id=642
+
+--- include/buildmacros
++++ include/buildmacros
+@@ -10,6 +10,7 @@
+ # during the "dist" phase (packaging).
+
+ LDFLAGS += $(LOADERFLAGS) $(LLDFLAGS)
++LTLDFLAGS += $(LOADERFLAGS)
+ LDLIBS = $(LLDLIBS) $(PLDLIBS) $(MALLOCLIB)
+
+ MAKEOPTS = --no-print-directory