summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-01-10 17:41:42 +0000
committerChristoph Mende <angelos@gentoo.org>2009-01-10 17:41:42 +0000
commit107559610024b1b72dad017bce18559ed023c9c2 (patch)
treebf5f03e3f1a4fe6bef7ba74ba59c4d8e8ff4ff9f /sys-apps/cinit/cinit-0.2.1.ebuild
parentInitial import (diff)
downloadhistorical-107559610024b1b72dad017bce18559ed023c9c2.tar.gz
historical-107559610024b1b72dad017bce18559ed023c9c2.tar.bz2
historical-107559610024b1b72dad017bce18559ed023c9c2.zip
QA: Prevent stripping (bug 252056), respect CC
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.28 x86_64
Diffstat (limited to 'sys-apps/cinit/cinit-0.2.1.ebuild')
-rw-r--r--sys-apps/cinit/cinit-0.2.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-apps/cinit/cinit-0.2.1.ebuild b/sys-apps/cinit/cinit-0.2.1.ebuild
index 6b50b8b02ac9..2823de4262e7 100644
--- a/sys-apps/cinit/cinit-0.2.1.ebuild
+++ b/sys-apps/cinit/cinit-0.2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cinit/cinit-0.2.1.ebuild,v 1.2 2007/09/27 14:20:23 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cinit/cinit-0.2.1.ebuild,v 1.3 2009/01/10 17:41:42 angelos Exp $
+
+inherit toolchain-funcs
DESCRIPTION="a fast, small and simple init with support for profiles"
HOMEPAGE="http://linux.schottelius.org/cinit/"
@@ -16,10 +18,13 @@ src_unpack() {
cd "${S}"
sed -i "/contrib+tools/d" Makefile
+ sed -i "/^STRIP/s/strip.*/true/" Makefile.include
}
src_compile() {
emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
OPTIMIZE="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
STRIP=/bin/true \