summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-24 02:05:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-24 02:05:54 +0000
commita60dc29b23f3bb6cc17c833e109f326441bd9fa5 (patch)
tree0d0c16c47cb4ecf020a49579dfe063fd8797f98d /sys-apps/debianutils/debianutils-2.13.1-r1.ebuild
parentversion bump (diff)
downloadhistorical-a60dc29b23f3bb6cc17c833e109f326441bd9fa5.tar.gz
historical-a60dc29b23f3bb6cc17c833e109f326441bd9fa5.tar.bz2
historical-a60dc29b23f3bb6cc17c833e109f326441bd9fa5.zip
Version bump to fix install locations #86349 by Peter Gantner.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-apps/debianutils/debianutils-2.13.1-r1.ebuild')
-rw-r--r--sys-apps/debianutils/debianutils-2.13.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/debianutils/debianutils-2.13.1-r1.ebuild b/sys-apps/debianutils/debianutils-2.13.1-r1.ebuild
new file mode 100644
index 000000000000..023e9cd0a407
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-2.13.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-2.13.1-r1.ebuild,v 1.1 2005/03/24 02:05:54 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="http://packages.debian.org/unstable/base/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE="static build"
+
+DEPEND=""
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dobin tempfile mktemp || die
+
+ if ! use build ; then
+ dobin run-parts || die "run-parts failed"
+ dosbin installkernel || die "installkernel failed"
+
+ into /usr
+ dosbin savelog mkboot || die "savelog/mkboot failed"
+
+ doman mktemp.1 tempfile.1 run-parts.8 savelog.8 \
+ installkernel.8 mkboot.8
+ cd debian
+ dodoc changelog control
+ fi
+}