summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-17 12:37:57 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-17 12:37:57 +0000
commit7a272d3e5634ec30acdc112b239400f4c7d15f98 (patch)
tree594723c5fb7b6180c570eb4dcd9908630c462f2c /sys-apps/dmapi
parentfixed writes out of image dir and corrected symlinks (diff)
downloadhistorical-7a272d3e5634ec30acdc112b239400f4c7d15f98.tar.gz
historical-7a272d3e5634ec30acdc112b239400f4c7d15f98.tar.bz2
historical-7a272d3e5634ec30acdc112b239400f4c7d15f98.zip
fixed out of image dir writes and corrected symlinks
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/dmapi-0.2.2-r1.ebuild39
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-0.2.2-r11
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-0.2.2-r1.ebuild b/sys-apps/dmapi/dmapi-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..317691288273
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-0.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-0.2.2-r1.ebuild,v 1.1 2002/01/17 12:37:57 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XFS data management API library"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ #let Steve Lord know that "install-dev" isn't mentioned in doc/INSTALL
+ make DESTDIR=${D} install install-dev || die
+ dosym /usr/lib/libdm.a /lib/libdm.a
+ dosym /usr/lib/libdm.la /lib/libdm.la
+ dosym /lib/libdm.so /usr/lib/libdm.so
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-0.2.2-r1 b/sys-apps/dmapi/files/digest-dmapi-0.2.2-r1
new file mode 100644
index 000000000000..81300783adb5
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-0.2.2-r1
@@ -0,0 +1 @@
+MD5 98a87591261b9f4baf3fcd209ab0f428 dmapi-0.2.2.src.tar.gz 57344