summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-01-27 17:35:52 +0000
committerSimon Stelling <blubb@gentoo.org>2006-01-27 17:35:52 +0000
commit186a33ab9c4060ee6af504caa01a07c475558259 (patch)
treea816c72022aceefd67611a3d8103e0c99867bc03 /sys-apps/dnotify/dnotify-0.18.0.ebuild
parentFix modular X deps. (diff)
downloadhistorical-186a33ab9c4060ee6af504caa01a07c475558259.tar.gz
historical-186a33ab9c4060ee6af504caa01a07c475558259.tar.bz2
historical-186a33ab9c4060ee6af504caa01a07c475558259.zip
fix problem stated in bug 118108 comment 6
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'sys-apps/dnotify/dnotify-0.18.0.ebuild')
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-apps/dnotify/dnotify-0.18.0.ebuild b/sys-apps/dnotify/dnotify-0.18.0.ebuild
index 662b20a1d35f..e692acaa77bf 100644
--- a/sys-apps/dnotify/dnotify-0.18.0.ebuild
+++ b/sys-apps/dnotify/dnotify-0.18.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/dnotify-0.18.0.ebuild,v 1.7 2006/01/27 15:41:47 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dnotify/dnotify-0.18.0.ebuild,v 1.8 2006/01/27 17:35:52 blubb Exp $
+
+inherit eutils
DESCRIPTION="Execute a command when the contents of a directory change"
HOMEPAGE="http://oskarsapps.mine.nu/dnotify.html"
@@ -13,6 +15,13 @@ IUSE="nls"
DEPEND="nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-nls.patch
+}
+
src_compile() {
econf $(use_enable nls) || die "failed to configure"
emake || die "failed to make"