summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-04-05 20:36:42 +0000
committerMichael Imhof <tantive@gentoo.org>2003-04-05 20:36:42 +0000
commitd3d1da239c9354ee84cf249cd67d385778bdcf15 (patch)
tree07721b545e017a0cc26f045df7d41301ad3714a9 /sys-apps/evms
parent~x86 -> x86 and added ~ppc. Some minor code style changes. (diff)
downloadhistorical-d3d1da239c9354ee84cf249cd67d385778bdcf15.tar.gz
historical-d3d1da239c9354ee84cf249cd67d385778bdcf15.tar.bz2
historical-d3d1da239c9354ee84cf249cd67d385778bdcf15.zip
Version bumped.
Diffstat (limited to 'sys-apps/evms')
-rw-r--r--sys-apps/evms/ChangeLog8
-rw-r--r--sys-apps/evms/evms-2.0.0.ebuild80
-rw-r--r--sys-apps/evms/files/digest-evms-2.0.01
3 files changed, 88 insertions, 1 deletions
diff --git a/sys-apps/evms/ChangeLog b/sys-apps/evms/ChangeLog
index d4386f7e47ee..5a9d1090ea36 100644
--- a/sys-apps/evms/ChangeLog
+++ b/sys-apps/evms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/evms
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/ChangeLog,v 1.15 2003/04/03 20:52:40 vladimir Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/ChangeLog,v 1.16 2003/04/05 20:36:42 tantive Exp $
+
+
+*evms-2.0.0 (06 Apr 2003)
+
+ 06 Apr 2003; Michael Imhof <tantive@gentoo.org>:
+ Version bumped.
*evms-1.2.1-r1 (05 Mar 2003)
diff --git a/sys-apps/evms/evms-2.0.0.ebuild b/sys-apps/evms/evms-2.0.0.ebuild
new file mode 100644
index 000000000000..a1b74bd16a70
--- /dev/null
+++ b/sys-apps/evms/evms-2.0.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/evms-2.0.0.ebuild,v 1.1 2003/04/05 20:36:42 tantive Exp $
+
+IUSE="ncurses gtk"
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Utilities for the IBM Enterprise Volume Management System"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.sourceforge.net/projects/evms"
+
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+#EVMS uses libuuid from e2fsprogs
+DEPEND="virtual/glibc
+ sys-apps/e2fsprogs
+ gtk? ( =x11-libs/gtk+-1* )
+ ncurses? ( sys-libs/ncurses )"
+
+
+src_compile() {
+ local interfaces="CommandLine,utilities,LvmUtils"
+ use ncurses && interfaces="ncurses,${interfaces}"
+ use gtk && interfaces="evmsgui,${interfaces}"
+
+ cd engine
+ ./configure \
+ --prefix=/usr \
+ --libdir=/lib \
+ --sbindir=/sbin \
+ --with-plugins=all \
+ --mandir=/usr/share/man \
+ --includedir=/usr/include \
+ --with-interfaces=${interfaces} \
+ --host=${CHOST} || die "bad ./configure"
+ #1.2.0 doesn't support parallel make
+ make || die "compile problem"
+}
+
+src_install() {
+ make -C engine DESTDIR=${D} install || die
+ dodoc CHANGES COPYING EVMS*.txt PLUGIN.IDS
+
+ # move static libraries to /usr/lib
+ dodir /usr/lib
+ mv -f ${D}/lib/*.a ${D}/usr/lib
+ # Create linker scripts for dynamic libs in /lib, else gcc
+ # links to the static ones in /usr/lib first. Bug #4411.
+ for x in ${D}/usr/lib/*.a
+ do
+ if [ -f ${x} ]
+ then
+ local lib="${x##*/}"
+ gen_usr_ldscript ${lib/\.a/\.so}
+ fi
+ done
+
+ # realize these symlinks now so they get included
+ cd ${D}/lib
+ rm -f libdlist.so libevms.so
+ ln -sf libevms-${PV}.so libevms.so.1
+ ln -sf libevms.so.1 libevms.so
+ ln -sf libdlist-1.0.so libdlist.so.1
+ ln -sf libdlist.so.1 libdlist.so
+
+ # the gtk+ frontend should live in /usr/sbin
+ if [ -n "`use gtk`" ]
+ then
+ dodir /usr/sbin
+ mv -f ${D}/sbin/evmsgui ${D}/usr/sbin
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/evms-init evms
+}
+
diff --git a/sys-apps/evms/files/digest-evms-2.0.0 b/sys-apps/evms/files/digest-evms-2.0.0
new file mode 100644
index 000000000000..2b093ac4504f
--- /dev/null
+++ b/sys-apps/evms/files/digest-evms-2.0.0
@@ -0,0 +1 @@
+MD5 34321d87bab4b863f4b5a7c21732643f evms-2.0.0.tar.gz 1693863